Bug 1301813 - BOOT FAILURE on fstab entry discrepancy at boot time
BOOT FAILURE on fstab entry discrepancy at boot time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 22:05 EST by Guy Smiley
Modified: 2016-01-26 08:14 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 08:14:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Smiley 2016-01-25 22:05:55 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

boot machine, unplug external hard-drive, reboot. Machine boots to black screen.

Steps to Reproduce:
1. boot machine with external HD attached
2. unplug external HD
3. Reboot

Actual results:

Machine boots to BLACK SCREEN

Expected results:

successfull boot

Additional info:

My machine is unbootable right now because of confusion in the fstab table. I apparently need to reinstall something that is not Fedora Linux on this machine to fix it.
Comment 1 Guy Smiley 2016-01-25 22:10:37 EST
Pulling out battery and removing power supply between reboots seems to have gotten me to boot. Failure to boot is a CRITICAL PROBLEM and Fedora is the only OS that seems to have this problem with fstab confusion though. I've submitted this bug before only to have it be completely ignored. I've stopped using Fedora on new machines because of this.
Comment 2 Guy Smiley 2016-01-25 22:21:15 EST
Welcome to emergency mode! Press control-D to reboot, unresponsive system.


until I plugged in the offending HD and rebooted
Comment 3 Guy Smiley 2016-01-25 22:22:10 EST
ability to BOOT should not be dependent on anything going on in fstab. This is a CRITICAL BUG
Comment 4 Kevin Fenzi 2016-01-25 22:44:15 EST
So, this is definitely not the right component here, this has nothing to do with fedora-release (which simply provides some configuration files). 

The behavior you hit is the default systemd behavior when a drive listed in /etc/fstab is unavailable on boot. It waits for a default 90 seconds trying to mount the drive, then goes to the emergency mode so an admin can fix it. 

If you want the drive to be optional (not required) on boot, modify /etc/fstab and add a 'nofail' to the options field for that mount (the 4th field). This will still try for 90 seconds on boot, if you want to disable or change that add "x-systemd.device-timeout=Number" to the option field as above. 

If you think the defaults should be different, please feel free to file a bug against the systemd component and explain why or talk to systemd folks upstream.
Comment 5 Guy Smiley 2016-01-25 23:17:39 EST
critical bug. should not be closed. failure of Fedora devs to address a critical issue here.

Part of the problem appears to be that the external drive is somehow mounted as root.

Why would you close an issue which can cause machines to FAIL TO BOOT!?

if the bug is mis-classified, then you should reclassify it for me, not just close it.

"Authentication is required to unmount ... /dev/sdb1 mounted by another user."

This is definitely related to the boot failure. The fix would be to make sure that external drives never get mounted as root. So fix it, don't bitch at me about it. I'm giving up on your OS because of this and all you guys can do is whine.
Comment 6 Guy Smiley 2016-01-25 23:20:12 EST
> The behavior you hit is the default systemd behavior when a drive listed in /etc/fstab is unavailable on boot. It waits for a default 90 seconds trying to mount the drive, then goes to the emergency mode so an admin can fix it.

This causes my machine to FAIL TO BOOT!!!

This is a terrible bug and it should be fixed.
Comment 7 Stephen Gallagher 2016-01-26 08:14:08 EST
Guy, this is not a bug. It is a misconfiguration. Yelling at people because you made a mistake is not likely to have a net-positive effect on finding a resolution.

Kevin provided you with a solution: fix your /etc/fstab so that the faulty drive is not being mounted. Now, this didn't work because *you installed Fedora on the external drive*. That is the root partition for Fedora.

If you unplug the drive, of course Fedora cannot boot, because it has no files. The only reason you even get to the repair menu is because the Fedora installer always puts the /boot partition on the first partition reported by the BiOS/EFI, which is generally guaranteed to be an internal drive.

Fedora would work just fine if you keep the drive that has it installed plugged in.

Note You need to log in before you can comment on or make changes to this bug.