This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 130185 - kernel panic after install of 2.4.21-15.0.4.EL
kernel panic after install of 2.4.21-15.0.4.EL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: s390utils (Show other bugs)
3.0
s390 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 15:31 EDT by Janet Smith
Modified: 2015-03-04 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 11:41:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Janet Smith 2004-08-17 15:31:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Applied latest kernel package (2.4.21-15.0.4.EL).  Failure upon rebooting.

Version-Release number of selected component (if applicable):
kernel-2.4.21-15.0.4.EL

How reproducible:
Always

Steps to Reproduce:
1. apply kernel-2.4.21-15.0.4.EL.rpm
2. reboot
3. using 3390-3 device
    

Actual Results:  Restarting system.                                  
                                   
Linux version 2.4.21-4.EL (bhcompile@byron.z900.redhat.com) (gcc
version 3.2.3 20030502 
                                                                     
                  
7:31:42 EDT 2003                                                     
                  
We are running under VM (31 bit mode)                                
                  
This machine has no PFIX support                                     
                  
This machine has an IEEE fpu                                         
                  
On node 0 totalpages: 32768                                          
                  
zone(0): 32768 pages.                                                
                  
zone(1): 0 pages.                                                    
                  
zone(2): 0 pages.                                                    
                  
Kernel command line: root=/dev/dasda1                                
                  
......
......
Restarting system.                                                   
                  
Linux version 2.4.21-4.EL (bhcompile@byron.z900.redhat.com) (gcc
version 3.2.3 20030502 
                                                                     
                  
7:31:42 EDT 2003                                                     
                  
We are running under VM (31 bit mode)                                
                  
This machine has no PFIX support                                     
                  
This machine has an IEEE fpu                                         
                  
On node 0 totalpages: 32768                                          
                  
zone(0): 32768 pages.                                                
                  
zone(1): 0 pages.                                                    
                  
zone(2): 0 pages.                                                    
                  
Kernel command line: root=/dev/dasda1  
Partition check:                                                  
 dasda:VOL1/  0X0209: dasda1                                      
 dasdp:CMS1/  DK0191: dasdp1                                      
dasd(eckd): We are interested in: CU 3880/00                      
dasd(eckd): We are interested in: CU 3990/00                      
dasd(eckd): We are interested in: CU 2105/00                      
dasd(eckd): We are interested in: CU 9343/00                      
Loading dasd_fba_mod.o module                                     
dasd(fba): FBA  discipline initializing                           
dasd(fba): We are interested in: Dev 9336/00 @ CU 6310/00         
dasd(fba): We are interested in: Dev 3370/00 @ CU 3880/00         
Mounting /proc filesystem                                         
Creating block devices                                            
Creating root device                                              
Mounting root filesystem                                          
VFS: Can't find ext2 filesystem on dev dasd(94,0).                
mount: error 22 mounting ext2                                     
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2         
umount /initrd/proc failed: 2                                     
Freeing unused kernel memory: 79k freed                           
Kernel panic: No init found.  Try passing init= option to kernel.
HCPGIR450W CP entered; disabled wait PSW 000A0000 800112EC 
 
                                                 



Expected Results:  Should have booted up with old kernel version.

Additional info:

Also applied latest s390utils rpm.

This was /boot & /etc/zipl.conf after applying rpms & before reboot:
[root@lnx18rh boot]# ls -l
total 14912
-rw-------    1 root     root        66048 Aug 17 13:26 bootmap
-rw-r--r--    1 root     root        48390 Jul 31 00:21
config-2.4.21-15.0.4.EL
-rw-r--r--    1 root     root        48095 Oct  3  2003 config-2.4.21-4.EL
drwxr-xr-x    2 root     root         4096 Oct 27  2003 grub
-rw-r--r--    1 root     root       597108 Aug 17 13:26
initrd-2.4.21-15.0.4.EL.img
-rw-r--r--    1 root     root       597073 Aug 17 13:15
initrd-2.4.21-4.EL.img
-rw-r--r--    1 root     root       597889 Nov 24  2003
initrd-2.4.21-4.EL.orig
-rw-r--r--    1 root     root          331 Oct 27  2003 kernel.h
-rw-r--r--    1 root     root        23108 Sep 11  2003 message
-rw-r--r--    1 root     root        21282 Sep 11  2003 message.ja
-rw-r--r--    1 root     root           17 Aug 17 13:03 parmfile.1
lrwxrwxrwx    1 root     root           22 Aug 17 11:23 System.map ->
System.map-2.4.21-4.EL
-rw-r--r--    1 root     root       272469 Jul 31 00:21
System.map-2.4.21-15.0.4.EL
-rw-r--r--    1 root     root       270194 Oct  3  2003
System.map-2.4.21-4.EL
-rw-r--r--    1 root     root         6109 Feb 19 04:41 tape0
-rwxr-xr-x    1 root     root      3175732 Jul 31 00:21
vmlinux-2.4.21-15.0.4.EL
-rwxr-xr-x    1 root     root      3163388 Oct  3  2003
vmlinux-2.4.21-4.EL
-rwxr-xr-x    1 root     root      3161344 Jul 31 00:21
vmlinuz-2.4.21-15.0.4.EL
-rwxr-xr-x    1 root     root      3144960 Oct  3  2003
vmlinuz-2.4.21-4.EL

[root@lnx18rh boot]# cat /etc/zipl.conf
[defaultboot]
default=linux
target=/boot/
[2.4.21-15.0.4.E]
        image=/boot/vmlinuz-2.4.21-15.0.4.EL
        ramdisk=/boot/initrd-2.4.21-15.0.4.EL.img
        parameters="root=/dev/dasda1    "
[linux]
        image=/boot/vmlinuz-2.4.21-4.EL
        ramdisk=/boot/initrd-2.4.21-4.EL.img
        parameters="root=/dev/dasda1    "
Comment 1 Pete Zaitcev 2004-08-19 19:50:06 EDT
This is pretty wild:

-rw-r--r--    1 root     root       597073 Aug 17 13:15
initrd-2.4.21-4.EL.img
-rw-r--r--    1 root     root       597889 Nov 24  2003
initrd-2.4.21-4.EL.orig

I cannot believe grubby would do this, ever. But who knows, maybe
it did.

Adding Jeremy to CC: in case he has any ideas.
Comment 2 Jeremy Katz 2004-08-19 21:29:34 EDT
grubby won't ever do anything like that.  We never rename things to a
.orig.
Comment 3 Pete Zaitcev 2004-08-19 21:52:58 EDT
So, the Janet's allegation or complaint was that some component
(grubby or not) messed up with PREVIOUS initrd (-4) while installing
ERRATA kernel (-15). Sounds fishy to me. I never heard of anything
like that nor can I imagine how it happened.

I think we should write it off and have Janet edit /etc/zipl.conf,
re-run zipl and be happy. Returning old -4.EL.img where it was
might be a good idea, too, just in case.

Probably the easiest way to do it is to attach the dasd to another
working client temporarily.

Let me know if this can be closed.
Comment 4 Janet Smith 2004-08-20 11:06:39 EDT
I had run zipl after the install of the new kernel just for good
measure.  Had I not run zipl, I would have booted OK on the old
kernel.  The problem turned out to be the syntax of /etc/zipl.conf as
coded by the installation of kernel-2.4.21-15.0.4.EL.rpm.  Once I
removed the blank spaces on the parameter and reran zipl.  It booted OK.
     parameters="root=/dev/dasda1    "

Thanks... Janet
Comment 5 Pete Zaitcev 2004-08-20 19:29:57 EDT
Looks like an RFE for s390utils. Or even a bug. I saw those spaces
but assumed they worked. s390utils belogs to pknirsch, I should
reassign the bug perhaps.
Comment 7 Pete Zaitcev 2004-09-11 01:51:52 EDT
Phil wrote on 8/30 that he'd try to reproduce the trailing space
problem from the comment #4.
Comment 8 Phil Knirsch 2004-11-05 11:55:40 EST
OK, i cannot reproduce the bug with the latest kernel and s390utils
package from RHEL3 U3, so i assume that the latest zipl version of the
s390utils fixes the problem.

Could you please give

  s390utils-1.2.4-5

and

  kernel-2.4.21-20.EL

a try?

Thanks,

Read ya, Phil
Comment 9 Phil Knirsch 2004-11-05 11:58:19 EST
And a comment from Jan Glauber, our IBM liaison from Boeblingen
suggests that at least in s390utils-1.3.x this works as expected and
that it might have been a bug in early 1.2.x version.

Read ya, Phil
Comment 10 Janet Smith 2004-11-11 16:36:38 EST
Sorry.  I'm not in a position to check out the latest s390utils.  So,
let's just call it fixed and closed this bug.

Thanks,
Janet
Comment 11 Mike Gahagan 2005-02-23 11:41:20 EST
Fixed by s390utils-1.2.4-5 in U3.

Note You need to log in before you can comment on or make changes to this bug.