Bug 1301956 - Upon Login using external Monitor System enters Suspend
Upon Login using external Monitor System enters Suspend
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 07:44 EST by Marcel Ziswiler
Modified: 2016-01-28 17:00 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 17:00:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora 23 Kernel 4.3.3-301.fc23.x86_64 HDMI Login Suspend Journal (390.60 KB, text/x-vhdl)
2016-01-26 07:44 EST, Marcel Ziswiler
no flags Details

  None (edit)
Description Marcel Ziswiler 2016-01-26 07:44:43 EST
Created attachment 1118470 [details]
Fedora 23 Kernel 4.3.3-301.fc23.x86_64 HDMI Login Suspend Journal

Description of problem:

Fedora 23 with latest 4.3.3-301.fc23.x86_64 kernel freshly booted automatically enters suspend mode upon logging in when using an external HDMI monitor connected to a docking station if laptop screen is closed.

Version-Release number of selected component (if applicable):

Fedora 23 fully updated with latest 4.3.3-301.fc23.x86_64 kernel

How reproducible:

Always

Steps to Reproduce:
1. power-on
2. login

Actual results:

System automatically suspends

Expected results:

Regular desktop should be shown upon logging in

Additional info:

Journal excerpt (full journal attached):

Jan 26 09:25:23 localhost.localdomain gnome-settings-daemon.desktop[1905]: (gnome-settings-daemon:1905): color-plugin-WARNING **: failed to set screen _ICC_PROFILE: Failed to open file '/home/zim/.local/share/icc/edid-e4c76289036f7297eeb2452f574627f2.icc': Permission denied
Jan 26 09:25:23 localhost.localdomain systemd-logind[1182]: Suspending...
Comment 1 Rui Matos 2016-01-26 09:09:07 EST
Does the monitor immediately turn off or do you have time to open a terminal and get xrandr's output? Something like

$ xrandr --verbose > /tmp/xrandr.txt

would be useful.

In addition, if you have a ~/.config/monitors.xml file, try to move it elsewhere (or just rename it) . Does that work around the problem?
Comment 2 Marcel Ziswiler 2016-01-28 17:00:04 EST
Thanks, unfortunately I did not get around trying above suggestions yet but it turns out some of the latest updates fixed the issue most possibly it was the 4.3.3-303.fc23.x86_64 kernel one.

Note You need to log in before you can comment on or make changes to this bug.