Bug 1302049 - S3 storage is not configured, but is listed in Keystone endpoints
S3 storage is not configured, but is listed in Keystone endpoints
Status: CLOSED DUPLICATE of bug 1317110
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Ivan Chavero
yeylon@redhat.com
: Automation, AutomationBlocker, ZStream
Depends On: 1138740
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 11:12 EST by Arx Cruz
Modified: 2016-04-18 03:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1138740
Environment:
Last Closed: 2016-03-22 20:16:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 287002 None None None 2016-03-03 03:04 EST
OpenStack gerrit 291048 None None None 2016-03-10 03:10 EST

  None (edit)
Comment 1 Alan Pevec 2016-02-26 14:23:57 EST
Having S3 in service catalog is clearly wrong, this should be cleaned up.
BTW nova-objectstore mentioned as workaround is gone in Mitaka.
Comment 2 Alan Pevec 2016-03-01 15:51:27 EST
So the issue is that puppet-swift enables this endpoint by default: https://github.com/openstack/puppet-swift/blob/master/manifests/keystone/auth.pp#L165 which is wrong, it should be defined ONLY when swift3 is enabled:
https://github.com/openstack/puppet-swift/blob/master/manifests/proxy/swift3.pp

Workaround in packstack could be to set explicit configure_s3_endpoint = false
Comment 3 Alan Pevec 2016-03-01 17:46:01 EST
This change added s3 endpoints as a part of a bigger change:
https://review.openstack.org/#/c/275617/1/packstack/puppet/templates/keystone_swift.pp@5

Lukas, ^ check comment there
Comment 4 Ivan Chavero 2016-03-03 03:04:22 EST
Added patch that sets configure_s3_endpoint = false

https://review.openstack.org/#/c/287002/
Comment 5 Alan Pevec 2016-03-03 19:32:39 EST
287002 was merged upstream - please backport where required
Comment 6 Ivan Chavero 2016-03-10 03:10:40 EST
Backported patch
https://review.openstack.org/#/c/291048
Comment 7 Alan Pevec 2016-03-22 20:16:52 EDT
Looks like this was duplicated and fixed as bug 1317110.

*** This bug has been marked as a duplicate of bug 1317110 ***

Note You need to log in before you can comment on or make changes to this bug.