Bug 1302076 - Minor update can sometimes fail on galera sync timeout being too short
Minor update can sometimes fail on galera sync timeout being too short
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Jiri Stransky
Udi Shkalim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 12:43 EST by Jiri Stransky
Modified: 2016-10-09 23:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-09 23:54:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1538218 None None None 2016-01-26 12:50 EST
OpenStack gerrit 272664 None None None 2016-01-26 12:49 EST

  None (edit)
Description Jiri Stransky 2016-01-26 12:43:27 EST
It seems that update can fail on some environments due to Galera sync timeout being too short.

We've seen the 360 second threshold broken and a failed update because of that, even though Galera eventually synced fine, clusterchecks OK and pcs status clean.

However, it's worth noting that this problem has only been seen once so far.
Comment 2 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Jaromir Coufal 2016-10-09 23:54:38 EDT
Could not reproduce. Please re-open if re-appears.

Note You need to log in before you can comment on or make changes to this bug.