Bug 1302367 - bad inputs for fields with number
bad inputs for fields with number
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
medium Severity medium
: ---
: 3
Assigned To: kamlesh
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 10:55 EST by Lubos Trilety
Modified: 2017-03-23 00:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:11:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add storage number fields (56.61 KB, image/png)
2016-01-27 10:55 EST, Lubos Trilety
no flags Details

  None (edit)
Description Lubos Trilety 2016-01-27 10:55:57 EST
Created attachment 1118827 [details]
add storage number fields

Description of problem:
There is several fields where integer number should be. For that reason there is special functionality which allows to increase or decrease the number. However it's possible to:
1. put there something which is not number at all
2. put there float number - e.g. 2.5 as Pools to create
3. put there minus number or 0
4. use the decrease functionality to go to zero or bellow

Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.5-0.1.alpha1.el7.x86_64
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch
rhscon-core-0.0.7-0.1.alpha1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Go to Storage
2. Click on Add Storage, choose some cluster and click on 'Next' button
3. see for fields with numbers, put there some values

Actual results:
No error message appears. All fields looks like they are accepted and in some cases they even are accepted and storage was created even with bad value. e.g. float number as number of pools or zero as number of replicas etc.

Expected results:
Some validation should be done before/after user click on 'Next' button. Moreover 'decrease' should not allow to go bellow 1.

Additional info:
see screen-shots in attachment
Comment 1 Lubos Trilety 2016-01-27 10:58:28 EST
Comment on attachment 1118827 [details]
add storage number fields

not all related fields are highlighted
Comment 3 Lubos Trilety 2016-07-01 11:12:58 EDT
Tested on:
rhscon-core-selinux-0.0.29-1.el7scon.noarch
rhscon-ui-0.0.43-1.el7scon.noarch
rhscon-core-0.0.29-1.el7scon.x86_64
rhscon-ceph-0.0.29-1.el7scon.x86_64

Most bad inputs are checked correctly, however there are still some issues.
1. A float number instead of integer number could be filled
2. Very long number could be used as a value

Note You need to log in before you can comment on or make changes to this bug.