Bug 1302416 - nova unable to delete floating-ip with neutron server error AttributeError: 'Query' object has no attribute 'one_or_none'
nova unable to delete floating-ip with neutron server error AttributeError: '...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Ihar Hrachyshka
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 14:39 EST by David Moreau Simard
Modified: 2016-04-26 19:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:04:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/nova/nova-api.log (5.05 KB, text/plain)
2016-01-27 14:40 EST, David Moreau Simard
no flags Details
/var/log/neutron/server.log (2.95 KB, text/plain)
2016-01-27 14:40 EST, David Moreau Simard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 261546 None None None 2016-01-28 15:34 EST

  None (edit)
Description David Moreau Simard 2016-01-27 14:39:41 EST
This problem manifested itself in CI jobs in delorean current mitaka tempest tests.

When attempting to delete a floating IP, nova-api will throw an internal error:
2016-01-27 18:48:04.735 32619 ERROR nova.api.openstack.extensions InternalServerError: Request Failed: internal server error while processing your request

This error originates from neutron, however:
2016-01-27 18:51:53.680 2397 ERROR neutron.api.v2.resource AttributeError: 'Query' object has no attribute 'one_or_none'

After speaking with ihrachys, it looks like we need to update sqlalchemy. The openstack-neutron specfile has "python-sqlalchemy >= 0.9.7" while upstream reqs.txt has ">=1.0.10".

Complete logs and configurations are available at: https://ci.centos.org/artifacts/rdo/weirdo-promote-mitaka-puppet-openstack-scenario001/13/puppet-openstack/logs/

Relevant stack traces are in attachment.
Comment 1 David Moreau Simard 2016-01-27 14:40 EST
Created attachment 1118861 [details]
/var/log/nova/nova-api.log
Comment 2 David Moreau Simard 2016-01-27 14:40 EST
Created attachment 1118862 [details]
/var/log/neutron/server.log
Comment 3 David Moreau Simard 2016-01-28 15:46:56 EST
An updated version of sqlalchemy made it to the deps repo. I have submitted a review for the bump: https://review.gerrithub.io/#/c/261546/
Comment 4 Ihar Hrachyshka 2016-03-24 10:58:49 EDT
Patch in question was merged in rpm-master.

Note You need to log in before you can comment on or make changes to this bug.