Bug 1302440 - Yubioath and yubioath-cli PySide not found
Yubioath and yubioath-cli PySide not found
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yubioath-desktop (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Jennings
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 17:17 EST by Phip
Modified: 2016-02-22 13:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 13:44:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phip 2016-01-27 17:17:19 EST
Description of problem:
yubioath and yubioath-cli fail to launch, complaining PySide is unavailable.

Version-Release number of selected component (if applicable):
yubioath-desktop.noarch 2.3.0-1.fc23

How reproducible:
always

Steps to Reproduce:
1. Execute yubioath or yubioath-cli

Actual results:

Traceback (most recent call last):
  File "/usr/bin/yubioath", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'PySide' distribution was not found and is required by yubioath-desktop

Expected results:

  Successful launch

Additional info:

  python-pyside.x86_64 1.2.2-4.fc23 package is installed as expected. Problem does not occur using the previous release, yubioath-desktop-2.2.1-1.fc23.
Comment 1 Seth Jennings 2016-01-28 16:58:56 EST
I just loaded a clean F23 Workstation install and was unable to reproduce this issue.

I did encounter this exact error during packaging and fixed it in the packaging with this patch:

http://pkgs.fedoraproject.org/cgit/rpms/yubioath-desktop.git/tree/fix-pyside-requirement.patch

Pulled from the upstream managed debian packaging

https://github.com/Yubico/yubioath-desktop-dpkg/blob/master/debian/patches/fix-pyside-requirement.diff

I made a request to get it into the upstream project and out of the packaging

https://github.com/Yubico/yubioath-desktop-dpkg/commit/25842b9c6a2ae5b9bb02b01c50b8ab88c390695b

But it hasn't gone anywhere afaict.

Can you confirm that the python-pyside package is actually installed?  It is an install dependency of this package.
Comment 2 Seth Jennings 2016-01-28 17:42:51 EST
Just fyi, I was getting some ImportErrors for pyusb not being installed while I attempted to recreate your issue.

Resolving that here:
https://bugzilla.redhat.com/show_bug.cgi?id=1302895
Comment 3 Phip 2016-02-22 13:37:58 EST
Pardon the delay. python-pyside is installed. I also was unable to reproduce on a clean F23 install, something must be fishy locally. You can close this. Thank you!

Note You need to log in before you can comment on or make changes to this bug.