Bug 1302445 - 'dnf' croaks with a traceback if "includeconf" is used
'dnf' croaks with a traceback if "includeconf" is used
Status: CLOSED DUPLICATE of bug 1209746
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 17:27 EST by Bruce Jerrick
Modified: 2016-02-01 08:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 08:02:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2016-01-27 17:27:40 EST
Description of problem:
'dnf' dies with a traceback if "includeconf=<filename>" is used in
  a config file.
Also, "includeconf" is not documented in dnf.conf(5) or yum2dnf(8)
  (in yum it was named "include"; that name got repurposed in dnf).
Also, in conf/parser.py, there are still several references to the
  old name "include" (where "includeconf" is actually meant).

Version-Release number of selected component:
  python3-dnf-1.1.5-1.fc23.noarch (SRPM is dnf-1.1.5-1.fc23.src.rpm)

How reproducible:
100%

Steps to Reproduce:
1. echo "includeconf=/dev/null" > /tmp/dnf.conf.test
2. dnf -c /tmp/dnf.conf.test check-update
(The lack of contents in /dev/null makes no difference.)

To check documentation:
1. man -s5 dnf.conf | grep "includeconf"
2. man -s8 yum2dnf.conf | grep "includeconf"    # name change is an incompatibility

To check bogus references to "include":
1. grep -w "include" /usr/lib/python3.4/site-packages/dnf/conf/parser.py

Actual results:
Traceback (most recent call last):
  ...
  File "/usr/lib/python3.4/site-packages/dnf/conf/parser.py", line 236, in _popfile
    self.name = self._incstack[-1].geturl()
  File "/usr/lib64/python3.4/tempfile.py", line 394, in __getattr__
    a = getattr(file, name)
AttributeError: '_io.TextIOWrapper' object has no attribute 'geturl'

Expected results:
No traceback.
Some mention of includeconf in man pages.
conf/parser.py refers to "includeconf", not "include".
Comment 1 Honza Silhan 2016-02-01 08:02:12 EST

*** This bug has been marked as a duplicate of bug 1209746 ***

Note You need to log in before you can comment on or make changes to this bug.