Bug 1302451 - The password in overcloudrc doesn't get changed between subsequent deploy runs
The password in overcloudrc doesn't get changed between subsequent deploy runs
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity high
: ---
: 11.0 (Ocata)
Assigned To: Hugh Brock
Shai Revivo
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 18:02 EST by Marius Cornea
Modified: 2017-09-09 02:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-08 17:46:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2016-01-27 18:02:43 EST
Description of problem:
The password in the resulting overcloudrc file doesn't change between subsequent deploy runs.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.10-26.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy initial overcloud
2. cp overcloudrc overcloudrc.initial
3. heat stack-delete overcloud
4. Rerun deploy command

Actual results:
stack@instack:~>>> diff overcloudrc.initial overcloudrc
7c7
< export no_proxy=,2001:db8:fd00:1000::10,172.16.23.10
---
> export no_proxy=,2001:db8:fd00:1000::10,172.16.23.10,172.16.23.10

Expected results:
The password gets changed for each new deployment.
Comment 3 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Ben Nemec 2017-03-08 11:36:52 EST
This behavior was intentional to allow users to set passwords prior to deployment.  As long as a password file is present (which it is after the first deployment) those passwords will be used.  To force generation of new passwords, the password file simply needs to be deleted.

That said, there have been major changes to how passwords work since OSP 7 and I suspect this is no longer an issue in OSP 10 and 11.  Can you check whether this is still happening?
Comment 6 Alex Schultz 2017-09-08 17:46:46 EDT
This has been fixed in newer releases. As previously indicated this was an intentional design for this version. I don't think we will be backporting the password generation work to this version. Closing the bug.
Comment 7 Marius Cornea 2017-09-09 02:17:23 EDT
Clearing the needinfo.

Note You need to log in before you can comment on or make changes to this bug.