Bug 1302465 - SELinux is preventing /usr/lib64/firefox/plugin-container from 'read' accesses on the file .gtkrc-2.0-kde4.
SELinux is preventing /usr/lib64/firefox/plugin-container from 'read' accesse...
Status: CLOSED DUPLICATE of bug 1067795
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d5be1a36e97161ca3d62f2dad16...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 19:06 EST by wintonian
Modified: 2016-01-27 19:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 19:21:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wintonian 2016-01-27 19:06:38 EST
Description of problem:
I clicked on the "seapplet" icon in the systray.
SELinux is preventing /usr/lib64/firefox/plugin-container from 'read' accesses on the file .gtkrc-2.0-kde4.

*****  Plugin mozplugger (99.1 confidence) suggests   ************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests   **************************

If you believe that plugin-container should be allowed read access on the .gtkrc-2.0-kde4 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .gtkrc-2.0-kde4 [ file ]
Source                        plugin-containe
Source Path                   /usr/lib64/firefox/plugin-container
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           firefox-43.0.3-1.fc23.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.2.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.4-300.fc23.x86_64 #1 SMP Mon
                              Jan 25 13:39:23 UTC 2016 x86_64 x86_64
Alert Count                   4
First Seen                    2016-01-27 23:24:12 GMT
Last Seen                     2016-01-28 00:01:55 GMT
Local ID                      a14f5c4a-33f3-434c-9986-2a9e2840e5b7

Raw Audit Messages
type=AVC msg=audit(1453939315.50:712): avc:  denied  { read } for  pid=11448 comm="plugin-containe" name=".gtkrc-2.0-kde4" dev="dm-1" ino=26716 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file permissive=1


type=AVC msg=audit(1453939315.50:712): avc:  denied  { open } for  pid=11448 comm="plugin-containe" path="/root/.gtkrc-2.0-kde4" dev="dm-1" ino=26716 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1453939315.50:712): arch=x86_64 syscall=open success=yes exit=EXDEV a0=7fb928e8eaa0 a1=0 a2=0 a3=4 items=0 ppid=10647 pid=11448 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/firefox/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,admin_home_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-158.2.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.4-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 802021
Comment 1 wintonian 2016-01-27 19:21:24 EST
Was running as root temporally whilst tinkering around, so I've closed this.
Comment 2 wintonian 2016-01-27 19:24:38 EST

*** This bug has been marked as a duplicate of bug 1067795 ***

Note You need to log in before you can comment on or make changes to this bug.