Bug 1302559 - [Webadmin] Add helper for windows VMs sysprep field
[Webadmin] Add helper for windows VMs sysprep field
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.0-beta
: ---
Assigned To: nobody nobody
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 02:45 EST by Ilanit Stein
Modified: 2016-12-14 10:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:52:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑4.1?
istein: planning_ack?
istein: devel_ack?
istein: testing_ack?


Attachments (Terms of Use)
Rhel VM custom script helper (63.54 KB, image/png)
2016-01-28 02:45 EST, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2016-01-28 02:45:37 EST
Created attachment 1119045 [details]
Rhel VM custom script helper

Description of problem:
Similarly to "custom script" field of rhel VMs, where there is a helper (question mark beside the field) - screen shot attached,
It would be good to have a helper for the windows VMs "sysprep" field. It need to be implemented for both occurrences of this field:
1. In Edit VM-> Initial run 
2. In Run once->Initial run 

The content of this helper can be something like:
sysprep answer file that will be attached to the virtual machine when it starts.
The format is a standard windows, for the specific windows version.
The values set in this section will run over same parameters that might have been set in the virtual machine edit VM, Run once dialog, or the [sysprep] floppy attached to the VM  

Version-Release number of selected component (if applicable):
rhevm 3.6.2-10
Comment 2 Michal Skrivanek 2016-04-22 10:48:02 EDT
pushed out due to capacity reasons
Comment 3 Tomas Jelinek 2016-12-14 10:52:59 EST
It is a low priority item, closing it as wont fix due to capacity.
Please feel free to reopen if you will find this important for you'r use case.

Note You need to log in before you can comment on or make changes to this bug.