Bug 1302825 - Last glibc update broke libstdc++ cmath header in rawhide
Last glibc update broke libstdc++ cmath header in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 12:33 EST by Milan Bouchet-Valat
Modified: 2016-02-05 08:04 EST (History)
13 users (show)

See Also:
Fixed In Version: glibc-2.22.90-32.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 06:56:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2016-01-28 12:33:05 EST
This morning, I was able to successfully build the Julia package in rawhide:
https://kojipkgs.fedoraproject.org//packages/julia/0.4.3/1.fc24/data/logs/x86_64/

But now, I get compilation errors (with the very same code):
> /usr/include/c++/6.0.0/cmath:615:11: error: '::isinf' has not been declared
>    using ::isinf;
>            ^~~~~
> /usr/include/c++/6.0.0/cmath:640:11: error: '::isnan' has not been declared
>    using ::isnan;
           ^~~~~
http://koji.fedoraproject.org/koji/taskinfo?taskID=12712802

The only packages which have been updated in the meantime are glibc, openssl-libs and gosrpm-macros. I strongly suspect glibc for obvious reasons, but in particular because isinf and isnan in cmath from libstdc++-devel interact with cmath.h from glibc. It looks like we need a more recent version of gcc, or a patch from upstream, to make them work together:
https://gcc.gnu.org/ml/libstdc++/2016-01/msg00023.html
https://sourceware.org/bugzilla/show_bug.cgi?id=19439
Comment 1 Jonathan Wakely 2016-01-28 12:43:22 EST
If glibc has been updated then it looks like gcc needs to be rebuilt in rawhide, see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69413#c2
Comment 2 Florian Weimer 2016-01-28 13:29:08 EST
I untagged the glibc build for now.
Comment 3 Milan Bouchet-Valat 2016-01-28 15:41:46 EST
Thanks, that indeed fixed the problem.
Comment 4 Florian Weimer 2016-01-28 16:03:50 EST
I've re-tagged it, in preparation for a gcc build which needs the new glibc.
Comment 5 Florian Weimer 2016-01-28 17:02:34 EST
Untagged again, GCC build is still running: http://koji.fedoraproject.org/koji/taskinfo?taskID=12715698
Comment 6 Florian Weimer 2016-02-05 06:56:46 EST
Fixed in rawhide.
Comment 7 Milan Bouchet-Valat 2016-02-05 08:04:22 EST
I can confirm the Julia build went fine in rawhide with glibc 2.22.90-32.fc24.

Note You need to log in before you can comment on or make changes to this bug.