This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302875 - kernel-4.3.4-300.fc23 /dev/lirc0 not created but is required for blaster functionality
kernel-4.3.4-300.fc23 /dev/lirc0 not created but is required for blaster func...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 15:55 EST by Warren Sturm
Modified: 2016-09-27 20:32 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 20:32:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working lirc0 from 4.2.8 (5.00 KB, text/x-vhdl)
2016-01-28 15:55 EST, Warren Sturm
no flags Details
output of journalctl for lirc_zilog load with 4.3.4 kernel (13.03 KB, text/plain)
2016-01-28 15:57 EST, Warren Sturm
no flags Details
/etc/systemd/system/lircd.service file (583 bytes, text/plain)
2016-01-28 15:58 EST, Warren Sturm
no flags Details

  None (edit)
Description Warren Sturm 2016-01-28 15:55:41 EST
Created attachment 1119294 [details]
Working lirc0 from 4.2.8

Description of problem:
Somewhere between 4.2.8 and 4.3.3 /dev/lirc0 is not being created when the lirc_zilog module is loaded.  The modules load with out error.  I have a modified lircd.service unit that loads lirc_zilog


Version-Release number of selected component (if applicable):

kernels after 4.2.8 through 4.5.0-rc0

How reproducible:

always

Steps to Reproduce:
1. 
2. 
3.

Actual results:

There is no /dev/lirc0

Expected results:

/dev/lirc0 exists after modules have been loaded.

Additional info:
The hardware used is a CX18 based Hauppauge HVR1600.

The 4.3.3 load of lirc_zilog is missing the i2c line that shows up in 4.2.8
Comment 1 Warren Sturm 2016-01-28 15:57 EST
Created attachment 1119295 [details]
output of journalctl for lirc_zilog load with 4.3.4 kernel
Comment 2 Warren Sturm 2016-01-28 15:58 EST
Created attachment 1119296 [details]
/etc/systemd/system/lircd.service file
Comment 3 Warren Sturm 2016-02-01 14:31:18 EST
It would appear that the interference is coming from ir_kbd_i2c.  If the module is blacklisted, /dev/lirc0 gets created.
Comment 4 Alec Leamas 2016-05-12 08:36:13 EDT
This is by definition a bug (feature?) of the zilog driver and thus a kernel issue. Re-assigning bug, sorry for long delay
Comment 5 Laura Abbott 2016-09-23 15:51:10 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 6 Warren Sturm 2016-09-27 13:09:24 EDT
I haven't seen this happen for the last several version of the kernel even with removing the blacklist for ir_kbd_i2c.  I am now running Fedora 24 with kernel-4.7.4-200.fc24.x86_64

Note You need to log in before you can comment on or make changes to this bug.