Bug 1302884 - [DOCS] [sme] Bad example for running the deployer template
[DOCS] [sme] Bad example for running the deployer template
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: brice
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 16:37 EST by Peter Larsen
Modified: 2016-08-08 19:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 19:49:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Larsen 2016-01-28 16:37:20 EST
Document URL: https://docs.openshift.com/enterprise/3.1/install_config/aggregate_logging.html#deploying-the-efk-stack

Section Number and Name: 1

Describe the issue: 
The "oc process" command uses "localhost" as the example master URL. This is a bad assumption. It should be replaced with the right master address. 

Suggestions for improvement: 
Remove the need to provide the master URL on the command line. Can't it be discovered and inserted automatically? If that's not possible, use a place holder for the correct master address. 

The error is, that only if the master is schedulable will this work.


Additional information:
Comment 1 brice 2016-05-16 01:42:21 EDT
Paul,

I've submitted a PR for this:

https://github.com/openshift/openshift-docs/pull/2100

Can I get an ack that this fulfills the BZ request here?

Thanks!
Comment 4 Peter Larsen 2016-06-13 21:04:28 EDT
(In reply to brice from comment #1)
> Paul,

If this was targeted me, sorry for being a bit late on a response here.
 
> I've submitted a PR for this:
> 
> https://github.com/openshift/openshift-docs/pull/2100

Yes - it removes the confusion about "localhost".
However, I thought "oc create" had been replaced with "oc apply" so it would work on updates too?

I don't believe there's a special chapter for upgrading EFK - so using a command that works for both uses cases would probably be best? 
 
> Can I get an ack that this fulfills the BZ request here?


From the localhost perspective, yeah this works fine.

> Thanks!
Comment 6 brice 2016-06-14 00:02:18 EDT
(In reply to Peter Larsen from comment #4)
> Yes - it removes the confusion about "localhost".
> However, I thought "oc create" had been replaced with "oc apply" so it would
> work on updates too?

Since my initial PR there's been a update to the section in the 3.2 docs. After a rebase, it now uses oc new-app instead of oc process. Is that what you mean?

> I don't believe there's a special chapter for upgrading EFK - so using a
> command that works for both uses cases would probably be best? 

There is a section actually:

3.1
https://docs.openshift.com/enterprise/3.1/install_config/upgrading/manual_upgrades.html#manual-upgrading-efk-logging-stack

3.2
https://docs.openshift.com/enterprise/3.2/install_config/upgrading/manual_upgrades.html#manual-upgrading-efk-logging-stack

However, I'm not sure what you mean about both use cases. Is what's in the section adequate?

> > Can I get an ack that this fulfills the BZ request here?
> 
> 
> From the localhost perspective, yeah this works fine.

Cool!

> > Thanks!
Comment 7 Peter Larsen 2016-08-08 10:08:05 EDT
(In reply to brice from comment #6)

Brice - sorry I didn't see your response until now :(

> (In reply to Peter Larsen from comment #4)
> > Yes - it removes the confusion about "localhost".
> > However, I thought "oc create" had been replaced with "oc apply" so it would
> > work on updates too?
> 
> Since my initial PR there's been a update to the section in the 3.2 docs.
> After a rebase, it now uses oc new-app instead of oc process. Is that what
> you mean?

Yeah - because I saw it fixed, I guess this bug got pushed out of mind here. You're quite right. 

Let's just close this case as solved.
Comment 8 brice 2016-08-08 19:49:24 EDT
Sure thing. Thanks a bunch, Peter!

Closing this. The work has already been done and in the links above.

Note You need to log in before you can comment on or make changes to this bug.