Bug 1302949 - [Docs] [Director] Address feedback on Chapter 8
[Docs] [Director] Address feedback on Chapter 8
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 01:13 EST by Andrew Dahms
Modified: 2017-07-17 22:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 00:50:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-01-29 01:13:24 EST
The following items must be addressed in Chapter 8. Creating Custom Configuration of the Director Installation and Usage Guide -

* In section 8.2 and 8.3, nameserver.yaml should be described using its full 
  path in post_config.yaml to ensure consistency in style with 8.1 and 8.5.

* In section 8.2, the file name should be pre_config.yaml instead of 
  post_config.yaml.

* In section 8.2, 'server' in nameserver.yaml should be of type 'string' 
  instead of 'json'. Moreover, 'servers' must be changed to 'server' in the 
  Important box, and the explanation in the box updated.

* In sections 8.1, 8.2, and 8.3, instances of '/etc/resolve.conf' must be
  changed to '/etc/resolv.conf'.

* In section 8.4, add an example of how to use the vnc_keymap parameter.
Comment 2 Andrew Dahms 2016-01-29 01:14:14 EST
Assigning to Dan for review.
Comment 3 Dan Macpherson 2016-02-08 23:16:19 EST
Andrew,

Everything should be fine except this item:

(In reply to Andrew Dahms from comment #0)
> * In section 8.2, 'server' in nameserver.yaml should be of type 'string' 
>   instead of 'json'. Moreover, 'servers' must be changed to 'server' in the 
>   Important box, and the explanation in the box updated.

It is definitely a 'json' value. However, it should be 'servers'.
Comment 5 Dan Macpherson 2016-02-12 02:46:37 EST
Draft of Chapter 8 available here:

http://file.bne.redhat.com/~dmacpher/OpenStack/7.3/Director/#chap-Creating_Custom_Configuration

adahms, how does it look now? Anything else required for this BZ?
Comment 6 Andrew Dahms 2016-02-15 01:35:00 EST
Hi Dan,

Thank you for making the changes.

I have received some feedback from the requester, as follows -

The requester has confirmed that they run into issues when 'servers' is set to 'json', but that it works when this is set to 'server' and 'string' respectively. Do you know if this is the intended behaviour, or if it might be a bug in the software?

Also, the requester has mentioned the following -

"Under ExtraPreDeployment in the resources section, "properties:" needs
to be aligned with "type". There are two extra spaces before "properties:"
and it causes an error."

Let me know if you have any questions.

Kind regards,

Andrew
Comment 7 Dan Macpherson 2016-02-15 02:21:08 EST
(In reply to Andrew Dahms from comment #6)
> Hi Dan,
> 
> Thank you for making the changes.
> 
> I have received some feedback from the requester, as follows -
> 
> The requester has confirmed that they run into issues when 'servers' is set
> to 'json', but that it works when this is set to 'server' and 'string'
> respectively. Do you know if this is the intended behaviour, or if it might
> be a bug in the software?

I checked and I owe you an apology. For *ExtraConfigPre it is a string. I must have confused it for the param for NodeExtraConfigPost (which is servers/json). My mistake. I'll update accordingly.

> Also, the requester has mentioned the following -
> 
> "Under ExtraPreDeployment in the resources section, "properties:" needs
> to be aligned with "type". There are two extra spaces before "properties:"
> and it causes an error."

Yep, this is correct. I'll make the fix for this too.

> 
> Let me know if you have any questions.
> 
> Kind regards,
> 
> Andrew
Comment 10 Andrew Dahms 2016-03-15 23:30:33 EDT
Hi Dan,

Thank you for the feedback - we will take the updates to the requester and will let you know if they provide any feedback.

Kind regards,

Andrew
Comment 12 Lucy Bopf 2016-03-23 21:13:12 EDT
Hi Dan,

Thanks for implementing the feedback. I have confirmed with the requester that the requirements for this bug are now complete.

Moving to VERIFIED.
Comment 13 Andrew Dahms 2016-04-13 00:50:46 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.