Bug 1302959 - Crash of sshd while running ipa-trust
Crash of sshd while running ipa-trust
Status: CLOSED DUPLICATE of bug 1275920
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos O'Donell
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 01:56 EST by Abhijeet Kasurde
Modified: 2016-02-02 07:52 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 07:52:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.crash.log (73.68 KB, text/plain)
2016-01-29 01:56 EST, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2016-01-29 01:56:01 EST
Created attachment 1119370 [details]
console.crash.log

Description of problem:
During automated run of ipa-trust functional using RHEL 7.2.z IPA server, RHEL 6.7.z IPA client with Windows 2012 r2 got following failure in SSHD 

:[New LWP 1279]
:[Thread debugging using libthread_db enabled]
:Using host libthread_db library "/lib64/libthread_db.so.1".
:Core was generated by `sshd: IPAAD2012R2\\ad'.
:Program terminated with signal 6, Aborted.
:#0  0x00007f2c065275f7 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
:56	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
:
:Thread 1 (Thread 0x7f2c09356840 (LWP 1279)):
:#0  0x00007f2c065275f7 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
:        resultvar = 0
:        pid = 1279
:        selftid = 1279
:#1  0x00007f2c06528ce8 in __GI_abort () at abort.c:90
:        save_stage = 2
:        act = {__sigaction_handler = {sa_handler = 0x7f2c0666e234, sa_sigaction = 0x7f2c0666e234}, sa_mask = {__val = {3, 140730717619259, 5, 139827062690823, 1, 139827062699507, 3, 140730717619236, 12, 139827062699511, 2, 139827062699511, 2, 140730717620048, 140730717620048, 140730717621808}}, sa_flags = 11, sa_restorer = 0x7ffe6c6ec950}
:        sigs = {__val = {32, 0 <repeats 15 times>}}
:#2  0x00007f2c06567317 in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7f2c06670988 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:196
:        ap = {{gp_offset = 40, fp_offset = 48, overflow_arg_area = 0x7ffe6c6ece40, reg_save_area = 0x7ffe6c6ecd50}}
:        ap_copy = {{gp_offset = 16, fp_offset = 48, overflow_arg_area = 0x7ffe6c6ece40, reg_save_area = 0x7ffe6c6ecd50}}
:        fd = 2
:        on_2 = <optimized out>
:        list = <optimized out>
:        nlist = <optimized out>
:        cp = <optimized out>
:        written = <optimized out>
:#3  0x00007f2c0656dd95 in malloc_printerr (ar_ptr=0x7f2c068ac760 <main_arena>, ptr=<optimized out>, str=0x7f2c0666e057 "corrupted double-linked list", action=3) at malloc.c:5013
:        buf = "00007f2c0a996260"
:        cp = <optimized out>
:        ar_ptr = 0x7f2c068ac760 <main_arena>
:        ptr = <optimized out>
:        str = 0x7f2c0666e057 "corrupted double-linked list"
:        action = 3
:#4  malloc_consolidate (av=0x7f2c068ac760 <main_arena>) at malloc.c:4160
:        fb = <optimized out>
:        maxfb = 0x7f2c068ac7b0 <main_arena+80>
:        p = 0x7f2c0a996220
:        nextp = 0x0
:        unsorted_bin = 0x7f2c068ac7b8 <main_arena+88>
:        first_unsorted = <optimized out>
:        nextchunk = <optimized out>
:        size = 112
:        nextsize = <optimized out>
:        prevsize = <optimized out>
:        nextinuse = <optimized out>
:        bck = <optimized out>
:        fwd = <optimized out>
:#5  0x00007f2c0656fe35 in _int_malloc (av=0x7f2c068ac760 <main_arena>, bytes=14) at malloc.c:3431
:        nb = 1088
:        bit = 0
:        map = 1279
:        errstr = 0x4ff <Address 0x4ff out of bounds>
:#6  0x00007f2c0657187c in __GI___libc_malloc (bytes=1072) at malloc.c:2881
:        ar_ptr = 0x7f2c068ac760 <main_arena>
:        victim = 0x6


Please look at attachment for full failure.


Version-Release number of selected component (if applicable):
ipa-server          - 4.2.0-15.el7_2.5
ipa-server-trust-ad - 4.2.0-15.el7_2.5

Client 
sssd - sssd-1.12.4-47.el6_7.7.x86_64

How reproducible:
Always
Comment 2 Petr Vobornik 2016-01-29 07:08:48 EST
sshd crash while using pam... Seems to be more in SSSD area. CCing Jakub for further triage.
Comment 3 Jakub Hrozek 2016-01-29 18:31:19 EST
Thanks. For now moving to sssd.

Abhijeet, it would be very helpful if you can provide us with a VM that reproduces this behaviour.
Comment 5 Lukas Slebodnik 2016-02-01 02:20:27 EST
Please provide version of glibc.
Comment 6 Abhijeet Kasurde 2016-02-02 07:16:39 EST
glibc-2.17-105.el7.x86_64.rpm
Comment 8 Lukas Slebodnik 2016-02-02 07:25:02 EST
(In reply to Abhijeet Kasurde from comment #6)
> glibc-2.17-105.el7.x86_64.rpm

Then this ticket is duplicate of BZ1275920 and shouls be already fixed in latest Z-stream update.
Comment 10 Jakub Hrozek 2016-02-02 07:52:15 EST

*** This bug has been marked as a duplicate of bug 1275920 ***

Note You need to log in before you can comment on or make changes to this bug.