This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302971 - [origin_userinterface_532]Show unsuitable page when project with long display name
[origin_userinterface_532]Show unsuitable page when project with long display...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: bpeterse
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 02:51 EST by zhou ying
Modified: 2016-12-09 16:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-09 16:53:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Iphone and IE11 and chrome (64.07 KB, image/png)
2016-02-17 22:11 EST, zhou ying
no flags Details
firfox and edge issue (126.37 KB, image/png)
2016-02-17 22:12 EST, zhou ying
no flags Details
display-name (152.67 KB, image/png)
2016-04-28 02:23 EDT, Yanping Zhang
no flags Details

  None (edit)
Description zhou ying 2016-01-29 02:51:47 EST
Description of problem:
Edit the project with a long display name, on home page the display name will not showd completed; on Overview page,the display name will showed by one line;
On setting page, the display name showed by one line, and the "Display Name" column squeezed and showed in two lines.

Version-Release number of selected component (if applicable):
openshift v1.1.1-277-gf45f63e
kubernetes v1.2.0-alpha.4-851-g4a65fa1
etcd 2.2.2

How reproducible:
always

Steps to Reproduce:
1. Start OpenShift and login;
2. Create a project with long display name , or edit it with login display name.
3. Check the project on home page, OverView page, Setting page.

Actual results:
3.1 On home page the display name will not showd completed;
3.2 On Overview page,the display name will showed by one line;
3.3 On setting page, the display name showed by one line, and the "Display Name" column squeezed and showed in two lines.

Expected results:
Show the login display name with correct format;

Additional info:
IE11/safari/Phone only on setting page, the display name showed by one line
Edge/firefox/chrome with the same results like the "Actual results".
Comment 1 bpeterse 2016-02-04 14:57:31 EST
"home" page assuming is the project list page (localhost:9000)
- the list of tiles will truncate the long name.  this is expected.

overview page project picker drop down
- this needs to truncate the name, it bleeds out

"settings page" on-page display does not truncate.  seems fine?

So it seems the most important issue to address is the project picker on the overview (and all other project pages) bleeding out the display name across the toolbar.  


Feel free to add screenshots if I am missing anything!
Comment 2 bpeterse 2016-02-04 16:30:59 EST
Have a WIP PR open to address this as we work out the details. https://github.com/openshift/origin/pull/7046
Comment 3 Steve Goodwin 2016-02-17 15:19:42 EST
Changes merged into master
Pull request shows screenshots
https://github.com/openshift/origin/pull/7267
Comment 4 zhou ying 2016-02-17 22:11 EST
Created attachment 1128129 [details]
Iphone and IE11 and chrome
Comment 5 zhou ying 2016-02-17 22:12 EST
Created attachment 1128130 [details]
firfox and edge issue
Comment 6 zhou ying 2016-02-17 22:18:35 EST
Confirmed with ami devenv-rhel7_3449, 
openshift v1.1.2-311-g84b45f9
kubernetes v1.2.0-origin
etcd 2.2.2+git

The "home" page and "Overview" page have show correctly; 
the main issuse is about "setting" page, please see the attachments;

The Iphone\IE11\Chrome\Safari, on the "setting" page , can't show the whole display name;

The firfox and edge , on the "setting" page, "Display Name" will showed on two lines.
Comment 7 Yanping Zhang 2016-04-28 02:23:21 EDT
The issue in comment 6 still exists on devenv-fedora_4053.
openshift v1.3.0-alpha.0-167-g4589987
kubernetes v1.3.0-alpha.1-331-g0522e63
etcd 2.3.0

The long display name is not shown completely on setting page on all browsers, and it also doesn't show well on project deleting page. pls refer to attachment "display-name".
Comment 8 Yanping Zhang 2016-04-28 02:23 EDT
Created attachment 1151736 [details]
display-name
Comment 9 bpeterse 2016-09-20 16:08:18 EDT
There have been a number of changes since this bug was created:
- The "settings" page shows the display name in an input, the input takes max width but can scroll back and forth keeping the text within its bounds.

- The "delete project" popup (accessible from the project list page) does not overflow even with a long display name.

- The project picker does not bleed, the dropdown stretches to the width of the screen matching the top bar. this seems acceptable.

- The above items seem appropriately handled on mobile browsers. The modal for deletion still shows all text w/appropriate margin/padding.  The other instances of text are appropriately truncated or have ellipsis. 

I believe we may have resolved this.
Comment 10 yapei 2016-09-21 02:15:18 EDT
Checked against 
openshift v1.4.0-alpha.0+16f2d39
kubernetes v1.4.0-beta.3+d19513f
etcd 3.0.9


Now "Settings" page has been removed, "Edit" and "Delete" project option is only provided on /console page.



1. Create a project with a long display name
2. Check display on /console page(all browsers)
3. Check display on project overview page (all browsers)
4. Check display after click edit icon on /console page(all browsers)
5. Check display after click delete icon on /console page(all browsers)

Checked against Chrome 53, Firefox 48, iPhone & iPad, Safari 9.1, IE 11, Edge 25, they all show well now

Move to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.