Bug 1303007 - Arch-specific libreoffice-headless Provide cannot be used as a build-require
Arch-specific libreoffice-headless Provide cannot be used as a build-require
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 04:40 EST by Petr Pisar
Modified: 2016-02-22 13:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 13:54:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-29 04:40:59 EST
Since commit:

commit 6456d6e5f30c55a43cd923e2fdbb3a6b79a3ca9d
Author: David Tardon <dtardon@redhat.com>
Date:   Sat Dec 26 16:26:28 2015 +0100

    make all deps arch-specific

libreoffice-core provides libreoffice-headless(x86-64) instead of libreoffice-headless. This makes the symbol unusable in build-requires because build-requires are forbidden to be arch-specific (https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#BuildRequires_and_.25.7B_isa.7D).

This prevents perl-OpenOffice-UNO from building <http://koji.fedoraproject.org/koji/taskinfo?taskID=12722131>.

We could change the build-require to libreoffice-core that is arch-independent, but I'd like to know your opinion. Is libreoffice-headless symbol deprecrated, or will you remove the %{?_isa} from the Provide?
Comment 1 David Tardon 2016-02-11 03:43:00 EST
We should provide both plain and %{?_isa} version, to match rpmbuild-generated Provides.

Note You need to log in before you can comment on or make changes to this bug.