Bug 130303 - Patch to allow xargs to read from file
Patch to allow xargs to read from file
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: findutils (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
http://savannah.gnu.org/patch/?func=d...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 17:43 EDT by Robin Green
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 09:28:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2004-08-18 17:43:08 EDT
Please could you apply, or nudge upstream to apply, this patch to
xargs that I wrote, adding an option to read filenames from a file
instead of stdin:

http://savannah.gnu.org/patch/?func=detailitem&item_id=2799

For me there are two key use cases for this patch:

1. I can use find to build an mplayer playlist, and then use xargs -a
playlist mplayer without losing keyboard controls in mplayer.

2. If I'm using xargs -a in a script, I can quickly substitute "gdb
--args prog" for "prog" to debug prog in the real-life context that it
is being called. Without the -a option, it would be impossible to do
it this convenient way, because gdb would not be able to read from the
keyboard.

Of course, it's useful for any interactive program that you might want
to call from xargs.
Comment 1 Tim Waugh 2004-12-10 09:28:43 EST
I think this has been applied upstream now.

Note You need to log in before you can comment on or make changes to this bug.