Bug 1303049 - pcl FTBFS in rawhide
pcl FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pcl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1302477
  Show dependency treegraph
 
Reported: 2016-01-29 07:32 EST by Jonathan Wakely
Modified: 2016-02-07 07:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 08:26:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2016-01-29 07:32:23 EST
It looks like there's a problem with MOC being unable to parse the latest Boost headers:

[ 95%] Generating include/pcl/apps/moc_openni_passthrough.cxx
cd /builddir/build/BUILD/pcl-0ddf11a6ad1175b6f1c253da003de20c1295cde0/build/apps/include/pcl/apps && /usr/lib64/qt4/bin/moc-qt4 @/builddir/build/BUILD/pcl-0ddf11a6ad1175b6f1c253da003de20c1295cde0/build/apps/include/pcl/apps/moc_openni_passthrough.cxx_parameters
usr/include/boost/type_traits/detail/has_prefix_operator.hp:46: Parse error at "BOOST_JOIN"
apps/CMakeFiles/pcl_openni_passthrough.dir/build.make:69: recipe for target 'apps/include/pcl/apps/moc_openni_passthrough.cxx' failed
Comment 1 Rich Mattes 2016-01-30 11:11:56 EST
Orion reported this upstream as well:

https://github.com/PointCloudLibrary/pcl/issues/1506

I can try the fix on the Arch AUR page as a work-around.  It looks like pcl is gearing up for a 1.8.0 release in the near future which is compatible with Qt5.  They've put out a release candidate for 1.8.0 that I can use to test with (maybe Qt5 moc doesn't have this problem?) and maybe push to rawhide in anticipation of the final 1.8.0 release.
Comment 2 Rich Mattes 2016-02-01 12:42:42 EST
PCL 1.8.0-rc1 builds with qt5 without issue, so I'm going to push that instead of patching 1.7.2.  I still need to do a little bit of auditing of the 1.8.0 tarball, as it looks like some non-free nvidia stuff is included in the cuda module, but I hope to clean that up and get a build done tonight or tomorrow.
Comment 3 Tim Niemueller 2016-02-01 18:09:10 EST
Causes Fawkes FTBFS on tolua++ upgrade. Rich, once you upgraded/fixed PCL can you trigger a build of the fawkes package, please?
Comment 4 Rich Mattes 2016-02-01 23:19:05 EST
No problem.  pcl is building now, hopefully the ARM portion will be done by tomorrow morning.
Comment 5 Tim Niemueller 2016-02-02 03:23:43 EST
Thanks a lot! I'd really like to see arm builders split out and produce separate artifacts. It's so annoying for virtually no gain (most of the time)...
Comment 6 Rich Mattes 2016-02-05 08:26:10 EST
The rawhide build of PCL is complete, so I'll close this out.  It looks like there's still some issues with fawkes on rawhide, I can try to take a look this weekend if you don't get to it sooner.
Comment 7 Tim Niemueller 2016-02-07 07:38:24 EST
Don't bother. We are releasing Fawkes 0.6 very soon and I will upgrade to that version which builds fine. Would otherwise require serious backporting of fixes.

Note You need to log in before you can comment on or make changes to this bug.