Bug 1303118 - registry command sets up liveness/readiness probes that do not work for secure registries
registry command sets up liveness/readiness probes that do not work for secur...
Status: CLOSED DUPLICATE of bug 1302956
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 10:37 EST by Jordan Liggitt
Modified: 2016-01-29 12:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 12:33:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1302956 None None None 2016-01-29 12:32 EST

  None (edit)
Description Jordan Liggitt 2016-01-29 10:37:36 EST
Description of problem:

The liveness/readiness probes set up by the `oadm registry` command fail if the registry is serving over TLS. There needs to be a way to indicate the HTTPS scheme should be used when creating the probes.

When the readiness/liveness probes fail, that triggers regular restarts of the registry.


Version-Release number of selected component (if applicable):
3.1.1


How reproducible:
Always


Steps to Reproduce:
1. Run 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 jooho lee 2016-01-29 12:33:26 EST
Duplicate bugzilla : 1302956
Comment 2 Jordan Liggitt 2016-01-29 12:33:37 EST

*** This bug has been marked as a duplicate of bug 1302956 ***

Note You need to log in before you can comment on or make changes to this bug.