Bug 1303121 - pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution ...
Status: CLOSED DUPLICATE of bug 1267446
Product: Fedora
Classification: Fedora
Component: rst2pdf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sergio Pascual
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 10:43 EST by Ankur Sinha (FranciscoD)
Modified: 2016-04-17 17:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-17 17:09:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2016-01-29 10:43:39 EST
Description of problem:
Doesn't work, says can't find pillow

Version-Release number of selected component (if applicable):
rst2pdf-0.93-6.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do anything with rst2pdf
2.
3.

Actual results:
Errors with traceback

Expected results:
Should work

Additional info:
$ rst2pdf -h
Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab

$ sudo dnf install python-pillow
[sudo] password for asinha: 
Last metadata expiration check performed 0:33:12 ago on Fri Jan 29 15:08:28 2016.
Package python-pillow-3.0.0-1.fc23.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
Comment 1 Pierre-YvesChibon 2016-03-22 09:10:24 EDT
I can confirm the bug :(
Comment 2 Dridi Boukelmoune 2016-04-17 17:09:38 EDT
A fix is available in updates-testing, see #1267446!

*** This bug has been marked as a duplicate of bug 1267446 ***

Note You need to log in before you can comment on or make changes to this bug.