Bug 1303258 - [regression] kernel 4.3.x - /sys/devices/virtual/thermal does not exist.
[regression] kernel 4.3.x - /sys/devices/virtual/thermal does not exist.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 18:59 EST by Hin-Tak Leung
Modified: 2016-02-26 07:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 07:57:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2016-01-29 18:59:33 EST
Description of problem:

I believe this is a kernel 4.3.x regression - it was working alright with 4.2.x.

# acpi -V
Battery 0: Discharging, 92%, 01:09:34 remaining
Battery 0: design capacity 3000 mAh, last full capacity 1142 mAh = 38%
Adapter 0: off-line
No support for device type: thermal
No support for device type: thermal

and I have floods of messages in /var/log/messages about:

gnome-shell.desktop: Gjs-Message: JS LOG: error reading: /sys/devices/virtual/thermal/cooling_device0/cur_state

/sys/devices/virtual/thermal does not exist, although I have:

# find /sys/  -type f -name '*temp*'
/sys/devices/pci0000:00/0000:00:01.0/hwmon/hwmon0/temp1_crit
/sys/devices/pci0000:00/0000:00:01.0/hwmon/hwmon0/temp1_crit_hyst
/sys/devices/pci0000:00/0000:00:01.0/hwmon/hwmon0/temp1_input
/sys/devices/pci0000:00/0000:00:18.3/hwmon/hwmon1/temp1_crit
/sys/devices/pci0000:00/0000:00:18.3/hwmon/hwmon1/temp1_crit_hyst
/sys/devices/pci0000:00/0000:00:18.3/hwmon/hwmon1/temp1_input
/sys/devices/pci0000:00/0000:00:18.3/hwmon/hwmon1/temp1_max
/sys/kernel/debug/kvm/halt_attempted_poll

I think I have at least two temperature sensors on this hardware.

Version-Release number of selected component (if applicable):
kernel-4.3.3-301.fc23.x86_64
kernel-4.3.3-303.fc23.x86_64
kernel-4.3.4-300.fc23.x86_64


How reproducible:
Always since upgraded to kernel 4.3.x from 4.2.x, I think.

Steps to Reproduce:
1. use kernel 4.3.x, run "acpi -V" , or look for /sys/devices/virtual/thermal
2.
3.

Actual results:
'acpi -V' shows:
No support for device type: thermal
No support for device type: thermal

Expected results:
'acpi -V' should tell me the temperatures from the sensors.

Additional info:
Comment 1 Hin-Tak Leung 2016-02-26 01:00:37 EST
Upgrading to 4.4.2 seems to have cured it.

# rpm -q kernel
kernel-4.3.4-300.fc23.x86_64
kernel-4.3.5-300.fc23.x86_64
kernel-4.4.2-300.fc23.x86_64

# uname -a 
Linux localhost.localdomain 4.4.2-300.fc23.x86_64 #1 SMP Fri Feb 19 15:40:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

# acpi -V
Battery 0: Discharging, 95%, 01:15:56 remaining
Battery 0: design capacity 3000 mAh, last full capacity 1142 mAh = 38%
Adapter 0: off-line
Cooling 0: Processor 0 of 10
Cooling 1: Processor 0 of 10
Cooling 2: Processor 0 of 10
Cooling 3: Processor 0 of 10

# sensors
radeon-pci-0008
Adapter: PCI adapter
temp1:        +56.0°C  (crit = +120.0°C, hyst = +90.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +55.4°C  (high = +70.0°C)
                       (crit = +115.5°C, hyst = +108.0°C)

fam15h_power-pci-00c4
Adapter: PCI adapter
power1:           N/A  (crit =  14.98 W)

# ls -l /sys/devices/virtual/thermal
total 0
drwxr-xr-x. 3 root root 0 Feb 26 05:52 cooling_device0
drwxr-xr-x. 3 root root 0 Feb 26 05:52 cooling_device1
drwxr-xr-x. 3 root root 0 Feb 26 05:52 cooling_device2
drwxr-xr-x. 3 root root 0 Feb 26 05:52 cooling_device3

would be nice to know what broke and what fixed, but otherwise this can close as CURRENTRELEASE .

Note You need to log in before you can comment on or make changes to this bug.