Bug 1303302 - External DP/HDMI display briefly blanking since upgrade to kernel-4.3.3-300.fc23.x86_64
External DP/HDMI display briefly blanking since upgrade to kernel-4.3.3-300.f...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 08:15 EST by Tore Anderson
Modified: 2016-02-27 07:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-27 07:42:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tore Anderson 2016-01-30 08:15:35 EST
Description of problem:

After having upgraded to kernel-4.3.3-300.fc23.x86_64, my external display (connected with a DP+-to-HDMI cable) has started to briefly blank. Basically the screen goes completely black for half a second or so before the picture comes back. It is as if the screensaver turned on to blank the screen and then immediately changed its mind.

I can also detect disturbances/distortions in the picture at times, sometimes (but not always) preceding one of these blanking events. So it kind of seems as if the kernel upgrade has lowered the signal quality of the DP+ output port, to the point where the monitor briefly loses the signal completely.

The laptop's internal screen is not affected, so it's not the actual screensaver that's turning on or anything like that.

Rebooting to kernel-4.2.8-300.fc23.x86_64 resolves the issue, I have never seen the blanking or disturbances/distortions with this kernel version.

The blankings/disturbances do not follow any regular pattern. Sometimes they come frequently, several times per minute, while other times I can use my laptop for an extended period of time without noticing a single incident.

Version-Release number of selected component (if applicable):

kernel-4.3.3-300.fc23.x86_64
kernel-4.3.3-303.fc23.x86_64

How reproducible:

100% in the sense that all I have to do use the laptop for a while and it'll surely happen. However I am not able to cause an immediate blanking episode at will.

Steps to Reproduce:
1. Boot laptop on kernel 4.3.3-300 or 4.3.3-303
2. Connect external display to DP+ port and activate it

Actual results:

After a while (could be soon, could be a long time) external screen will briefly appear to switch off/blank. This is of course very disturbing if you're actively using the system at that point in time.

Expected results:

Stable picture, not flickering to black or having any other disturbances.

Additional info:

My laptop is a HP EliteBook Folio 9470m (D9Y17AV). The graphics card is a «Intel Corporation 3rd Gen Core processor Graphics Controller» according to lspci.
Comment 1 Tore Anderson 2016-02-01 07:42:21 EST
The issue also occurs with kernel 4.3.4-300.fc23.x86_64.

I just noticed some errors in the kernel log which seem relevant. These have only occurred twice since boot, so they don't happen every time the screen blanks (that happens far more often).


[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder B
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder B FIFO underrun
Comment 2 Tore Anderson 2016-02-13 03:39:50 EST
Issue persists in 4.3.5-300.fc23.x86_64.

With this version I've spotted this kernel error message:

i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
Comment 3 Tore Anderson 2016-02-15 15:15:55 EST
I've bisected the problem and reported it upstream:

https://lists.freedesktop.org/archives/intel-gfx/2016-February/087653.html
Comment 4 Tore Anderson 2016-02-27 07:42:18 EST
Upstream has found the bug has been found and a patch series that fixes it has been posted:

https://patchwork.freedesktop.org/series/3735/

I assume that this will eventually make its way to the Fedora kernel RPMs, so I'm closing this bug as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.