Bug 1303330 - Acer Aspire E15 touchpad not working since kernel version 4.3.3-301
Acer Aspire E15 touchpad not working since kernel version 4.3.3-301
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 17:05 EST by Szőke Károly
Modified: 2016-01-31 03:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 03:56:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (66.39 KB, text/plain)
2016-01-30 17:05 EST, Szőke Károly
no flags Details
content of /proc/bus/input/devices (4.29 KB, text/plain)
2016-01-30 17:07 EST, Szőke Károly
no flags Details

  None (edit)
Description Szőke Károly 2016-01-30 17:05:59 EST
Created attachment 1119677 [details]
dmesg

Description of problem:
Since the kernel version 4.3.3-301 the touchpad doesn't work. The touchpad worked with kernel 4.3.3-300, but from 4.3.3-301 it doesn't work.
Acer Aspire E15 E5-571-31J6

Version-Release number of selected component (if applicable):
Fedora 23 4.3.3-303.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1.boot 4.3.3-300 kernel, it works
2.boot 4.3.3-301 kernel, it isn't work
3.boot 4.3.3-303 kernel, it isn't work

Actual results:
touchpad is not working

Expected results:
touchpad is working

Additional info:
xinput output:
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ELAN0501:00 04F3:300B UNKNOWN           	id=13	[slave  pointer  (2)]
⎜   ↳ Feeling-tech-USB product Feeling-tech-USB product	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ HD WebCam                               	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=14	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=15	[slave  keyboard (3)]
    ↳ Feeling-tech-USB product Feeling-tech-USB product	id=11	[slave  keyboard (3)]
    ↳ Feeling-tech-USB product Feeling-tech-USB product	id=16	[slave  keyboard (3)]
Comment 1 Szőke Károly 2016-01-30 17:07 EST
Created attachment 1119678 [details]
content of /proc/bus/input/devices
Comment 2 Josh Boyer 2016-01-30 21:00:01 EST
Please test 4.3.4-300 in updates-testing.  This is most likely a duplicate of bug 1296677
Comment 3 Szőke Károly 2016-01-31 03:56:01 EST
Yes, it works with 4.3.4-300 in update repo. I'm waiting for the new kernel. Thank you!

Note You need to log in before you can comment on or make changes to this bug.