Bug 1303336 - [abrt] fedora-cert: proxyclient.py:466:send_request:AuthError: Unable to log into server. Invalid authentication tokens. Send new username and password
[abrt] fedora-cert: proxyclient.py:466:send_request:AuthError: Unable to log ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5580b302de49a1cf4442dea0a04...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 20:33 EST by Justin W. Flory
Modified: 2016-01-30 20:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-30 20:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.72 KB, text/plain)
2016-01-30 20:34 EST, Justin W. Flory
no flags Details
File: environ (3.42 KB, text/plain)
2016-01-30 20:34 EST, Justin W. Flory
no flags Details

  None (edit)
Description Justin W. Flory 2016-01-30 20:33:58 EST
Version-Release number of selected component:
fedora-cert-0.5.10.5-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/fedora-cert -u jflory7 -n
dso_list:       python-fedora-0.7.1-1.fc23.noarch
executable:     /usr/bin/fedora-cert
kernel:         4.3.3-301.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
proxyclient.py:466:send_request:AuthError: Unable to log into server.  Invalid authentication tokens.  Send new username and password

Traceback (most recent call last):
  File "/usr/bin/fedora-cert", line 74, in <module>
    main(opts)
  File "/usr/bin/fedora-cert", line 38, in main
    fedora_cert.create_user_cert(username)
  File "/usr/lib/python2.7/site-packages/fedora_cert/__init__.py", line 104, in create_user_cert
    cert = fas.user_gencert()
  File "/usr/lib/python2.7/site-packages/fedora/client/fas2.py", line 881, in user_gencert
    request = self.send_request('user/dogencert', auth=True)
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 367, in send_request
    auth_params=auth_params, retries=retries, timeout=timeout)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 466, in send_request
    'Unable to log into server.  Invalid'
AuthError: Unable to log into server.  Invalid authentication tokens.  Send new username and password

Local variables in innermost frame:
username: 'jflory7'
retries: 0
cookies: <RequestsCookieJar[]>
req_params: None
timeout: 120.0
url: 'https://admin.fedoraproject.org/accounts/user/dogencert'
session_id: None
self: <fedora.client.fas2.AccountSystem object at 0x7f7c97aa7c50>
auth: None
method: 'user/dogencert'
headers: {'Accept': 'application/json', 'User-agent': 'Fedora Account System Client/0.7.1'}
num_tries: 0
complete_params: {'login': 'Login', 'password': 'THIS_WAS_VALID_PASSWORD_BUT_NOW_IS_NULL', 'user_name': 'jflory7'}
http_status: 403
auth_params: {'username': 'jflory7', 'password': 'THIS_WAS_VALID_PASSWORD_BUT_NOW_IS_NULL'}
file_params: {}
password: 'THIS_WAS_VALID_PASSWORD_BUT_NOW_IS_NULL'
data: None
response: <Response [403]>
Comment 1 Justin W. Flory 2016-01-30 20:34:02 EST
Created attachment 1119706 [details]
File: backtrace
Comment 2 Justin W. Flory 2016-01-30 20:34:03 EST
Created attachment 1119707 [details]
File: environ
Comment 3 Justin W. Flory 2016-01-30 20:37:14 EST
Did not mean to go through with reporting this, it is not a bug and was an error on my end. Please ignore, apologies for any accidental notifications.

Note You need to log in before you can comment on or make changes to this bug.