Bug 1303355 - gnutls: Broken Key Usage flags in certificates created with certtool
gnutls: Broken Key Usage flags in certificates created with certtool
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1305197
  Show dependency treegraph
 
Reported: 2016-01-31 05:25 EST by Nikos Mavrogiannopoulos
Modified: 2016-02-21 11:25 EST (History)
2 users (show)

See Also:
Fixed In Version: gnutls-3.3.21-1.fc22 gnutls-3.4.9-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 21:24:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Mavrogiannopoulos 2016-01-31 05:25:58 EST
[copy of https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813243 ]

Description of problem:

I found that certtool writes broken Key Usage extensions to generated
certificates. For example, when using the follwing template (from the
mod_gnutls test suite) to create a CA, neither of the requested flags
(certificate signing and CRL signing) is set.

cn="Testing Authority"
ca
cert_signing_key
crl_signing_key

The key usage extension ends up present but empty. This leads to all
certificates issued by the CA getting rejected because signing
certificates violates the certificate's constraints. I've reported the
bug upstream [1] and there is a simple patch [2]. Please apply it to the
version in Sid.

[1] http://lists.gnutls.org/pipermail/gnutls-devel/2016-January/007861.html
[2] https://gitlab.com/gnutls/gnutls/commit/7d3caedb8df9d04eee9513cb5b3b417ae29927f5
Comment 1 Fedora Update System 2016-02-03 05:29:40 EST
gnutls-3.3.21-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d5fbc3b7eb
Comment 2 Fedora Update System 2016-02-03 18:25:26 EST
gnutls-3.3.21-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d5fbc3b7eb
Comment 3 Fedora Update System 2016-02-15 08:27:32 EST
gnutls-3.4.9-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3796cd10e9
Comment 4 Fedora Update System 2016-02-17 01:29:17 EST
gnutls-3.4.9-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3796cd10e9
Comment 5 Fedora Update System 2016-02-20 21:24:28 EST
gnutls-3.3.21-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-02-21 08:00:34 EST
gnutls-3.4.9-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2016-02-21 11:19:56 EST
gnutls-3.4.9-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-02-21 11:25:50 EST
gnutls-3.4.9-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.