Bug 1303461 - [DOCS] [3.2] Document the process for updating bootstrap policies
[DOCS] [3.2] Document the process for updating bootstrap policies
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Thien-Thi Nguyen
XiaochuanWang
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 18:11 EST by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 05:46:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2016-01-31 18:11:04 EST
In OSE 3.2, the method by which an administrator can manage and update the bootstrap policy for users and systems has been made easier.

There is no current documentation around this feature and the process by which the cluster admin can create and manage these policies needs to be documented.

This new feature allows working with role definitions and bindings to ensure an easy experience for the tenant while working with policies.

Suggested outline:
-- What is the problem that we are trying to solve by having bootstrap policies
-- How can admins achieve it without this feature
-- How can admins achieve it with this feature

Dev for this feature is:
David Eads

Trello card is:
https://trello.com/c/kLVprEpA/470-3-make-bootstrap-policy-updates-easy

QA for the feature is:
Xiaochuan Wang

Likely Guide is:
As a new topic in the Cluster Admin Guide: https://docs.openshift.com/enterprise/3.1/admin_guide/index.html
Comment 2 Alex Dellapenta 2016-03-09 11:07:02 EST
(In reply to Thien-Thi Nguyen from comment #1)
> Current documentation (copied from trello card):
> 
> -
> https://docs.openshift.org/latest/install_config/upgrades.html#updating-
> policy-definitions
> -
> https://docs.openshift.org/latest/architecture/additional_concepts/
> authorization.html
> - https://docs.openshift.org/latest/admin_guide/manage_scc.html

Do you feel these satisfy this BZ?
Comment 3 Thien-Thi Nguyen 2016-03-09 16:02:23 EST
(In reply to Alex Dellapenta from comment #2)

> Do you feel these satisfy this BZ?

No, they barely mention bootstrap policies.
Comment 4 Thien-Thi Nguyen 2016-03-09 16:13:57 EST
On second thought, i was fooled by a simple grep on "bootstrap".  The above-mentioned pages do indeed touch on the "oadm policy reconcile-*" commands, which is how the functionality is exposed to the user.  I think this documentation is sufficient for now.
Comment 6 XiaochuanWang 2016-03-10 00:09:22 EST
Thank you for summarize tnguyen, I think the following 4 documents are sufficient, but I was wondering if need to add documents in github repo: openshift/openshift-docs
Comment 7 Thien-Thi Nguyen 2016-03-10 05:46:56 EST
(In reply to XiaochuanWang from comment #6)

Thanks for the quick response.

> following 4 documents are sufficient, but I was wondering if
> need to add documents in github repo: openshift/openshift-docs

Luckily, there is no need, since the documents linked (in comment #5) are already in the repo.

Moving status to CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.