Bug 130355 - no fstab entry for digital camera created
no fstab entry for digital camera created
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 11:20 EDT by Pekka Pietikäinen
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 14:21:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diff of lshal between no camera plugged in and camera plugged in (2.44 KB, text/plain)
2004-08-19 11:21 EDT, Pekka Pietikäinen
no flags Details
diff of tree /sys (8.06 KB, text/plain)
2004-08-19 11:22 EDT, Pekka Pietikäinen
no flags Details
hald debug output (8.31 KB, text/plain)
2004-08-19 14:09 EDT, Pekka Pietikäinen
no flags Details

  None (edit)
Description Pekka Pietikäinen 2004-08-19 11:20:54 EDT
Description of problem:

Separating this from #130290 so that one can be closed, 
basically no fstab entry is generated for my digital camera. 
Diff of lshal and tree /sys before and after camera gets plugged in
attached.

in /var/log/messages:

Aug 19 18:15:20 the kernel: usb 4-2: new full speed USB device using
address 5
Aug 19 18:15:21 the hal.hotplug[16439]: got info for
/class/scsi_host/host5 (waited 0 ms)
Aug 19 18:15:21 the kernel: scsi5 : SCSI emulation for USB Mass
Storage devices
Aug 19 18:15:21 the kernel:   Vendor: NIKON     Model: NIKON DSC E995
   Rev: 1.00
Aug 19 18:15:21 the kernel:   Type:   Direct-Access                  
   ANSI SCSI revision: 02
Aug 19 18:15:21 the kernel: SCSI device sdb: 250368 512-byte hdwr
sectors (128 MB)
Aug 19 18:15:21 the hal.hotplug[16480]: got info for /block/sdb
(waited 0 ms)
Aug 19 18:15:21 the kernel: sdb: Write Protect is off
Aug 19 18:15:21 the kernel: sdb: assuming drive cache: write through
Aug 19 18:15:21 the hal.hotplug[16487]: got info for /block/sdb/sdb1
(waited 0 ms)
Aug 19 18:15:21 the kernel:  sdb: sdb1
Aug 19 18:15:21 the hal.hotplug[16494]: got info for
/class/scsi_device/5:0:0:0 (waited 0 ms)
Aug 19 18:15:21 the hal.hotplug[16501]: got info for
/class/scsi_generic/sg1 (waited 0 ms)
Aug 19 18:15:21 the kernel: Attached scsi removable disk sdb at scsi5,
channel 0, id 0, lun 0
Aug 19 18:15:21 the kernel: Attached scsi generic sg1 at scsi5,
channel 0, id 0, lun 0,  type 0
Aug 19 18:15:21 the hal.hotplug[16474]: got info for
/devices/pci0000:00/0000:00:10.2/usb4/4-2/4-2:1.0 (waited 200 ms)
Aug 19 18:15:22 the scsi.agent[16446]: disk at
/devices/pci0000:00/0000:00:10.2/usb4/4-2/4-2:1.0/host5/5:0:0:0
Aug 19 18:15:22 the hal.hotplug[16508]: Dont know how to wait for scsi
at /devices/pci0000:00/0000:00:10.2/usb4/4-2/4-2:1.0/host5/5:0:0:0;
sleeping 1000 ms
Aug 19 18:15:22 the hal.hotplug[16510]: got info for
/devices/pci0000:00/0000:00:10.2/usb4/4-2 (waited 0 ms)
Aug 19 18:15:23 the udev[16517]: creating device node '/dev/sdb'
Aug 19 18:15:23 the udev[16518]: creating device node '/dev/sdb1'
Aug 19 18:15:23 the udev[16520]: creating device node '/dev/sg1'
Aug 19 18:15:46 the kernel: usb 4-2: USB disconnect, address 5
Aug 19 18:15:46 the udev[16573]: removing device node '/dev/sg1'
Aug 19 18:15:47 the udev[16611]: removing device node '/dev/sdb'
Aug 19 18:15:47 the udev[16596]: removing device node '/dev/sdb1'
Aug 19 18:17:04 the su(pam_unix)[16639]: session opened for user root
by pp(uid=500)

(with the host number incrementing every time I turn the camera on ->
it looks like it doesn't get fully removed from the kernel or whatnot)
Comment 1 Pekka Pietikäinen 2004-08-19 11:21:43 EDT
Created attachment 102878 [details]
diff of lshal between no camera plugged in and camera plugged in
Comment 2 Pekka Pietikäinen 2004-08-19 11:22:34 EDT
Created attachment 102879 [details]
diff of tree /sys
Comment 3 David Zeuthen 2004-08-19 13:29:32 EDT
Hi,

please shutdown hald and try to run it as root as 'hald --daemon=no 2>
hald_out.txt'. Then wait a while (30 secs), plug in the camera and
remove it again after a while (30 secs) and then attach the debug log.

Thanks
Comment 4 Pekka Pietikäinen 2004-08-19 14:08:41 EDT
Hrmn... Something mystically fixed it (I just upgraded to latest
rawhide including kernel and hald among others, rebooted and it
started working just ok). Log attached in any case.
Comment 5 Pekka Pietikäinen 2004-08-19 14:09:12 EDT
Created attachment 102890 [details]
hald debug output
Comment 6 David Zeuthen 2004-08-19 14:21:35 EDT
Ok, good to know that it works because USB Mass Storage have more or
less been what I've always tested with (I'm the upstream maintainer as
well) and it's been working quite nicely from the beginning.

Just curious; what was the old version?

Thanks,
David
Comment 7 Pekka Pietikäinen 2004-08-19 14:44:06 EDT
08/13/04 22:57:17 Updated: hal-devel 0.2.96-2.i386
08/13/04 22:57:17 Updated: hal 0.2.96-2.i386
08/13/04 22:57:17 Updated: hal-gnome 0.2.96-2.i386

Too old to be that :-)

08/18/04 13:00:07 Updated: hal-devel 0.2.97-1.i386
08/18/04 13:00:07 Updated: hal 0.2.97-1.i386
08/18/04 13:00:07 Updated: hal-gnome 0.2.97-1.i386

So this... Probably the reboot cleared it up. I did restart hal and
messagebus etc., but maybe that wasn't enough. *shrug*

Note You need to log in before you can comment on or make changes to this bug.