Bug 1303590 - Never repack .jar files
Never repack .jar files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.3
Unspecified Unspecified
low Severity low
: ovirt-3.6.5
: 3.6.3
Assigned To: Juan Hernández
Juan Hernández
: CodeChange, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 06:45 EST by Juan Hernández
Modified: 2016-04-21 10:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:44:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Hernández 2016-02-01 06:45:43 EST
Currently the build process of the engine disables repacking of .jar files only for quick builds, intended for tests. It does so setting the "__jar_repack" global macro to 0:

  %global __jar_repack 0

But this repackaging isn't really useful for us, as repackging is intended for packages that contain multilib .jar files, as described here:

  https://www.redhat.com/archives/fedora-devel-java-list/2008-September/msg00041.html

As repackaging takes a long time, it would be better for us to always disable it, as already done upstream in the master branch:

  packaging: Never repack .jar files
  https://gerrit.ovirt.org/52917
Comment 1 Yaniv Lavi 2016-02-03 03:14:57 EST
Please test this on brew prior to merging this change to stable branches.
Comment 4 Sandro Bonazzola 2016-03-22 11:52:30 EDT
As far as I can tell, it's already in 3.6.4 code. Maybe even in 3.6.3.
Comment 5 Gil Klein 2016-03-23 04:35:33 EDT
(In reply to Sandro Bonazzola from comment #4)
> As far as I can tell, it's already in 3.6.4 code. Maybe even in 3.6.3.
Moving to 3.6.5 for verification as we won't have time to verify it for 3.6.4
Comment 6 Pavel Stehlik 2016-04-01 03:37:37 EDT
Nothing for QE, thus acked & reassigned contact.
Comment 7 Gil Klein 2016-04-11 03:39:58 EDT
Juan, is there anything QE can do to test this BZ?
Comment 8 Juan Hernández 2016-04-11 04:11:33 EDT
No Gil, nothing other than making sure that the engine works as usual.
Comment 9 Gil Klein 2016-04-14 03:36:35 EDT
Moving to verified based on comment #8.

Note You need to log in before you can comment on or make changes to this bug.