Bug 1303781 - libreoffice calc and math appears to translate csv to some other Asian in appearance (to me) language
libreoffice calc and math appears to translate csv to some other Asian in app...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 18:56 EST by morgan read
Modified: 2016-03-28 07:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 03:33:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
csv file imported into libreoffice Calc or Math (1.57 KB, text/plain)
2016-02-01 18:56 EST, morgan read
no flags Details
libreoffice Calc/ Math csv import window (80.04 KB, image/png)
2016-02-01 18:58 EST, morgan read
no flags Details
csv imported into libreoffce Calc (183.40 KB, image/png)
2016-02-01 18:59 EST, morgan read
no flags Details
ods file created by csv import (8.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-01 19:03 EST, morgan read
no flags Details

  None (edit)
Description morgan read 2016-02-01 18:56:42 EST
Created attachment 1120260 [details]
csv file imported into libreoffice Calc or Math

Description of problem:
Import CSV and get Chinese/ Japanese (Asian looking, my apologies for any misplaced assumptions) characters!!!

Version-Release number of selected component (if applicable):
$ rpm -qa libreoffice
libreoffice-4.4.7.2-1.fc22.x86_64

How reproducible:
Always since I started using f22 from f20 about the New Year

Steps to Reproduce:
1. Have CSV
2. Import into Calc or Math
3. Get really weird stuff

Actual results:
Really weird stuff - Asian appearing characters all in cell A:1

Expected results:
Sensible spreadsheet

Additional info:
Attached screen shots and original csv
Comment 1 morgan read 2016-02-01 18:58 EST
Created attachment 1120273 [details]
libreoffice Calc/ Math csv import window
Comment 2 morgan read 2016-02-01 18:59 EST
Created attachment 1120274 [details]
csv imported into libreoffce Calc
Comment 3 morgan read 2016-02-01 19:03 EST
Created attachment 1120275 [details]
ods file created by csv import
Comment 4 Stephan Bergmann 2016-02-02 03:33:40 EST
attachment 1120273 [details] shows that you chose "Unicode (UTF-16)" as character set, you should switch that to a single-byte ASCII superset that actually matches your input file's encoding, "Unicode (UTF-8)"
Comment 5 morgan read 2016-02-04 17:29:09 EST
Oops - buy why isn't libreoffice adopting the system/ user character coding - is that the bug?  Never had to think about that before.
Comment 6 Stephan Bergmann 2016-02-05 03:07:21 EST
(In reply to morgan read from comment #5)
> Oops - buy why isn't libreoffice adopting the system/ user character coding
> - is that the bug?  Never had to think about that before.

I very much assume that you accidentally happened to switch that setting in the dialog once to UTF-16 (from UTF-8, presumably), by some unintentional keyboard or mouse interaction.  I'm not aware how we would ever preselect UTF-16 here.
Comment 7 Eike Rathke 2016-02-05 06:37:38 EST
It might had happened when opening a file with a UTF-16 BOM, or if content starts with 16-bit values where the high byte represents a control character other than CR,LF,TAB, in which case Unicode UTF-16 is assumed and selected. And the settings are remembered and preselected for the next file to be opened.
Comment 8 morgan read 2016-03-28 07:38:34 EDT
Thanks Eike, sounds plausible :)
M

Note You need to log in before you can comment on or make changes to this bug.