Bug 130379 (IT_47197) - redhat-config-users does not use the password age defaults in /etc/login.defs
Summary: redhat-config-users does not use the password age defaults in /etc/login.defs
Status: CLOSED ERRATA
Alias: IT_47197
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-users   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-19 19:02 UTC by Eric Paris
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 21:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch r-c-users so it honors defaults set in /etc/libuser.conf (or in libuser itself) (518 bytes, patch)
2004-11-01 22:11 UTC, David Lehman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:440 low SHIPPED_LIVE Updated redhat-config-users package 2005-05-19 04:00:00 UTC

Description Eric Paris 2004-08-19 19:02:06 UTC
Description of problem:
The redhat-config-users should use the defaults for password aging as
shown in /etc/login.defs since that option is not available during
user creation.  It is known that such an option is available after the
user is created by accessing the properties of the user.  But the tool
should accept the defaults for portions of user creation which are not
able to be set at creation time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add line "PASS_MAX_DAYS   90" to /etc/login.defs
2.create a new user using the redhat-config-users tool
    

Actual Results:  line in /etc/shadow file looks like:
test:$1$z0aIfTjx$OMl7w.IlZyy01E2Ac.jRg1:12649:0:99999:7:::

note expiration of 99999

Expected Results:  line in /etc/shadow file looks like:
test:$1$z0aIfTjx$OMl7w.IlZyy01E2Ac.jRg1:12649:0:90:7:::

note expiration of 90

Comment 1 Eric Paris 2004-08-20 20:24:16 UTC
editting /etc/libuser.conf and setting 
LU_SHADOWMAX = 90
had no effect on the user created using redhat-config-users either.

Comment 2 David Lehman 2004-11-01 22:11:43 UTC
Created attachment 106051 [details]
Patch r-c-users so it honors defaults set in /etc/libuser.conf (or in libuser itself)

Comment 4 Nils Philippsen 2004-11-08 16:34:15 UTC
I've built redhat-config-users-1.1.18-3 which fixes this problem -- it
doesn't honor login.defs but libuser.conf -- and opened an erratum for it.

Comment 5 Tim Powers 2005-05-19 21:39:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-440.html



Note You need to log in before you can comment on or make changes to this bug.