Bug 1303821 - Failed to deploy SAM-1.4.1-RHEL-6-20141113.0 on RHEL-6.8-20160125.0
Failed to deploy SAM-1.4.1-RHEL-6-20141113.0 on RHEL-6.8-20160125.0
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.4.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 01:16 EST by qianzhan
Modified: 2016-02-18 22:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 13:59:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description qianzhan 2016-02-02 01:16:43 EST
Description of problem:
Failed to deploy SAM-1.4.1-RHEL-6-20141113.0 on RHEL-6.8-20160125.0

Version-Release number of selected component (if applicable):
candlepin-0.9.6.5-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.9.6.5-1.el6sam.noarch
candlepin-tomcat6-0.9.6.5-1.el6sam.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3.1-1.el6sam.noarch
katello-cli-common-1.4.3.1-1.el6sam.noarch
katello-common-1.4.3.28-1.el6sam_splice.noarch
katello-configure-1.4.5.1-3.el6sam.noarch
katello-glue-candlepin-1.4.3.28-1.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3.28-1.el6sam_splice.noarch
katello-headpin-1.4.3.28-1.el6sam_splice.noarch
katello-headpin-all-1.4.3.28-1.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
ruby193-rubygem-katello-redhat-access-engine-0.0.1-1.el6sam.noarch
thumbslug-0.0.40-1.el6sam.noarch
thumbslug-selinux-0.0.40-1.el6sam.noarch

How reproducible:
always

Steps to Reproduce:
1. Install RHEL-6.8-20160125.0, and register to qa candlepin and auto-attach.
2. Install katello.


Actual results:
Failed in step 2:
[root@dhcp-128-71 ~]#  yum install -y katello-headpin-all
Loaded plugins: product-id, refresh-packagekit, search-disabled-repos, security,
              : subscription-manager
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello-headpin-all.noarch 0:1.4.3.28-1.el6sam_splice will be installed

...


--> Processing Dependency: rpm = 4.8.0-47.el6 for package: rpm-build-4.8.0-47.el6.x86_64
---> Package ruby193-rubygem-polyglot.noarch 0:0.3.3-5.el6_4 will be installed
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.2.15-47.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
           Requires: httpd = 2.2.15-47.el6_7.1
           Installed: httpd-2.2.15-51.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               httpd = 2.2.15-51.el6
           Available: httpd-2.2.15-5.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-5.el6
           Available: httpd-2.2.15-9.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6
           Available: httpd-2.2.15-9.el6_1.2.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6_1.2
           Available: httpd-2.2.15-9.el6_1.3.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6_1.3
           Available: httpd-2.2.15-15.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-15.el6
           Available: httpd-2.2.15-15.el6_2.1.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-15.el6_2.1
           Available: httpd-2.2.15-26.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-26.el6
           Available: httpd-2.2.15-28.el6_4.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-28.el6_4
           Available: httpd-2.2.15-29.el6_4.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-29.el6_4
           Available: httpd-2.2.15-30.el6_5.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-30.el6_5
           Available: httpd-2.2.15-31.el6_5.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-31.el6_5
           Available: httpd-2.2.15-39.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-39.el6
           Available: httpd-2.2.15-45.el6.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-45.el6
           Available: httpd-2.2.15-47.el6_7.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-47.el6_7
           Available: httpd-2.2.15-47.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-47.el6_7.1
Error: Package: glibc-2.12-1.166.el6_7.3.i686 (rhel-6-server-eus-rpms)
           Requires: glibc-common = 2.12-1.166.el6_7.3
           Installed: glibc-common-2.12-1.190.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               glibc-common = 2.12-1.190.el6
           Available: glibc-common-2.12-1.7.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6
           Available: glibc-common-2.12-1.7.el6_0.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.3
           Available: glibc-common-2.12-1.7.el6_0.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.4
           Available: glibc-common-2.12-1.7.el6_0.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.5
           Available: glibc-common-2.12-1.25.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.25.el6
           Available: glibc-common-2.12-1.25.el6_1.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.25.el6_1.3
           Available: glibc-common-2.12-1.47.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6
           Available: glibc-common-2.12-1.47.el6_2.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.5
           Available: glibc-common-2.12-1.47.el6_2.9.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.9
           Available: glibc-common-2.12-1.47.el6_2.12.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.12
           Available: glibc-common-2.12-1.80.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6
           Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.3
           Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.4
           Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.5
           Available: glibc-common-2.12-1.80.el6_3.6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.6
           Available: glibc-common-2.12-1.80.el6_3.7.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.7
           Available: glibc-common-2.12-1.107.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6
           Available: glibc-common-2.12-1.107.el6_4.2.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.2
           Available: glibc-common-2.12-1.107.el6_4.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.4
           Available: glibc-common-2.12-1.107.el6_4.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.5
           Available: glibc-common-2.12-1.132.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.132.el6_5.1.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.1
           Available: glibc-common-2.12-1.132.el6_5.2.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6_5.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.3
           Available: glibc-common-2.12-1.132.el6_5.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.4
           Available: glibc-common-2.12-1.149.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6
           Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.4
           Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.7
           Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.9
           Available: glibc-common-2.12-1.163.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.163.el6
           Available: glibc-common-2.12-1.164.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.164.el6
           Available: glibc-common-2.12-1.165.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.165.el6
           Available: glibc-common-2.12-1.166.el6.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6
           Available: glibc-common-2.12-1.166.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6_7.1
           Available: glibc-common-2.12-1.166.el6_7.3.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6_7.3
Error: Package: rpm-build-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
           Requires: rpm = 4.8.0-47.el6
           Installed: rpm-4.8.0-49.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               rpm = 4.8.0-49.el6
           Available: rpm-4.8.0-12.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-12.el6
           Available: rpm-4.8.0-16.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-16.el6
           Available: rpm-4.8.0-16.el6_1.1.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-16.el6_1.1
           Available: rpm-4.8.0-19.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-19.el6
           Available: rpm-4.8.0-19.el6_2.1.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-19.el6_2.1
           Available: rpm-4.8.0-27.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-27.el6
           Available: rpm-4.8.0-32.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-32.el6
           Available: rpm-4.8.0-37.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-37.el6
           Available: rpm-4.8.0-38.el6_6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-38.el6_6
           Available: rpm-4.8.0-46.el6.x86_64 (rhel-6-server-htb-rpms)
               rpm = 4.8.0-46.el6
           Available: rpm-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
               rpm = 4.8.0-47.el6
Error: Package: policycoreutils-python-2.0.83-24.el6.x86_64 (rhel-6-server-eus-rpms)
           Requires: policycoreutils = 2.0.83-24.el6
           Installed: policycoreutils-2.0.83-27.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               policycoreutils = 2.0.83-27.el6
           Available: policycoreutils-2.0.83-19.1.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.1.el6
           Available: policycoreutils-2.0.83-19.8.el6_0.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.8.el6_0
           Available: policycoreutils-2.0.83-19.18.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.18.el6
           Available: policycoreutils-2.0.83-19.21.el6_2.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.21.el6_2
           Available: policycoreutils-2.0.83-19.24.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.24.el6
           Available: policycoreutils-2.0.83-19.30.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.30.el6
           Available: policycoreutils-2.0.83-19.39.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.39.el6
           Available: policycoreutils-2.0.83-19.47.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.47.el6
           Available: policycoreutils-2.0.83-19.47.el6_6.1.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.47.el6_6.1
           Available: policycoreutils-2.0.83-21.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-21.el6
           Available: policycoreutils-2.0.83-22.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-22.el6
           Available: policycoreutils-2.0.83-23.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-23.el6
           Available: policycoreutils-2.0.83-24.el6.x86_64 (rhel-6-server-eus-rpms)
               policycoreutils = 2.0.83-24.el6
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: 1:mod_ssl-2.2.15-47.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
           Requires: httpd = 2.2.15-47.el6_7.1
           Installed: httpd-2.2.15-51.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               httpd = 2.2.15-51.el6
           Available: httpd-2.2.15-5.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-5.el6
           Available: httpd-2.2.15-9.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6
           Available: httpd-2.2.15-9.el6_1.2.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6_1.2
           Available: httpd-2.2.15-9.el6_1.3.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-9.el6_1.3
           Available: httpd-2.2.15-15.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-15.el6
           Available: httpd-2.2.15-15.el6_2.1.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-15.el6_2.1
           Available: httpd-2.2.15-26.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-26.el6
           Available: httpd-2.2.15-28.el6_4.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-28.el6_4
           Available: httpd-2.2.15-29.el6_4.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-29.el6_4
           Available: httpd-2.2.15-30.el6_5.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-30.el6_5
           Available: httpd-2.2.15-31.el6_5.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-31.el6_5
           Available: httpd-2.2.15-39.el6.x86_64 (rhel-6-server-aus-rpms)
               httpd = 2.2.15-39.el6
           Available: httpd-2.2.15-45.el6.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-45.el6
           Available: httpd-2.2.15-47.el6_7.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-47.el6_7
           Available: httpd-2.2.15-47.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
               httpd = 2.2.15-47.el6_7.1
Error: Package: glibc-2.12-1.166.el6_7.3.i686 (rhel-6-server-eus-rpms)
           Requires: glibc-common = 2.12-1.166.el6_7.3
           Installed: glibc-common-2.12-1.190.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               glibc-common = 2.12-1.190.el6
           Available: glibc-common-2.12-1.7.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6
           Available: glibc-common-2.12-1.7.el6_0.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.3
           Available: glibc-common-2.12-1.7.el6_0.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.4
           Available: glibc-common-2.12-1.7.el6_0.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.7.el6_0.5
           Available: glibc-common-2.12-1.25.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.25.el6
           Available: glibc-common-2.12-1.25.el6_1.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.25.el6_1.3
           Available: glibc-common-2.12-1.47.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6
           Available: glibc-common-2.12-1.47.el6_2.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.5
           Available: glibc-common-2.12-1.47.el6_2.9.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.9
           Available: glibc-common-2.12-1.47.el6_2.12.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.47.el6_2.12
           Available: glibc-common-2.12-1.80.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6
           Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.3
           Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.4
           Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.5
           Available: glibc-common-2.12-1.80.el6_3.6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.6
           Available: glibc-common-2.12-1.80.el6_3.7.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.80.el6_3.7
           Available: glibc-common-2.12-1.107.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6
           Available: glibc-common-2.12-1.107.el6_4.2.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.2
           Available: glibc-common-2.12-1.107.el6_4.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.4
           Available: glibc-common-2.12-1.107.el6_4.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.107.el6_4.5
           Available: glibc-common-2.12-1.132.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.132.el6_5.1.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.1
           Available: glibc-common-2.12-1.132.el6_5.2.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6_5.3.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.3
           Available: glibc-common-2.12-1.132.el6_5.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.132.el6_5.4
           Available: glibc-common-2.12-1.149.el6.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6
           Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.4
           Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.7
           Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (rhel-6-server-aus-rpms)
               glibc-common = 2.12-1.149.el6_6.9
           Available: glibc-common-2.12-1.163.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.163.el6
           Available: glibc-common-2.12-1.164.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.164.el6
           Available: glibc-common-2.12-1.165.el6.x86_64 (rhel-6-server-htb-rpms)
               glibc-common = 2.12-1.165.el6
           Available: glibc-common-2.12-1.166.el6.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6
           Available: glibc-common-2.12-1.166.el6_7.1.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6_7.1
           Available: glibc-common-2.12-1.166.el6_7.3.x86_64 (rhel-6-server-eus-rpms)
               glibc-common = 2.12-1.166.el6_7.3
Error: Package: rpm-build-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
           Requires: rpm = 4.8.0-47.el6
           Installed: rpm-4.8.0-49.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               rpm = 4.8.0-49.el6
           Available: rpm-4.8.0-12.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-12.el6
           Available: rpm-4.8.0-16.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-16.el6
           Available: rpm-4.8.0-16.el6_1.1.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-16.el6_1.1
           Available: rpm-4.8.0-19.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-19.el6
           Available: rpm-4.8.0-19.el6_2.1.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-19.el6_2.1
           Available: rpm-4.8.0-27.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-27.el6
           Available: rpm-4.8.0-32.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-32.el6
           Available: rpm-4.8.0-37.el6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-37.el6
           Available: rpm-4.8.0-38.el6_6.x86_64 (rhel-6-server-aus-rpms)
               rpm = 4.8.0-38.el6_6
           Available: rpm-4.8.0-46.el6.x86_64 (rhel-6-server-htb-rpms)
               rpm = 4.8.0-46.el6
           Available: rpm-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
               rpm = 4.8.0-47.el6
Error: Package: policycoreutils-python-2.0.83-24.el6.x86_64 (rhel-6-server-eus-rpms)
           Requires: policycoreutils = 2.0.83-24.el6
           Installed: policycoreutils-2.0.83-27.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201601251859.x86_64/6.8)
               policycoreutils = 2.0.83-27.el6
           Available: policycoreutils-2.0.83-19.1.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.1.el6
           Available: policycoreutils-2.0.83-19.8.el6_0.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.8.el6_0
           Available: policycoreutils-2.0.83-19.18.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.18.el6
           Available: policycoreutils-2.0.83-19.21.el6_2.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.21.el6_2
           Available: policycoreutils-2.0.83-19.24.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.24.el6
           Available: policycoreutils-2.0.83-19.30.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.30.el6
           Available: policycoreutils-2.0.83-19.39.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.39.el6
           Available: policycoreutils-2.0.83-19.47.el6.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.47.el6
           Available: policycoreutils-2.0.83-19.47.el6_6.1.x86_64 (rhel-6-server-aus-rpms)
               policycoreutils = 2.0.83-19.47.el6_6.1
           Available: policycoreutils-2.0.83-21.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-21.el6
           Available: policycoreutils-2.0.83-22.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-22.el6
           Available: policycoreutils-2.0.83-23.el6.x86_64 (rhel-6-server-htb-rpms)
               policycoreutils = 2.0.83-23.el6
           Available: policycoreutils-2.0.83-24.el6.x86_64 (rhel-6-server-eus-rpms)
               policycoreutils = 2.0.83-24.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
As step 2.
Additional info:
Comment 1 Mike McCune 2016-02-03 13:59:55 EST
This doesn't look like it has anything to do with SAM 1.4, the conflicts are within the set of repos you have enabled for RHEL:

 rpm-build-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
           Requires: rpm = 4.8.0-47.el6

looks like you are trying to pull from rhel-6-server-eus-rpms repo which is definitely not RHEL 6.8 (6.7) so you are getting conflicts. You need to have your system configured to pull base OS from the RHEL 6.8 compose repository and not EUS.

I provisioned a fresh RHEL 6.8 Beta system and installed SAM 1.4 just fine:

# yum -y install katello-headpin-all
Loaded plugins: product-id, search-disabled-repos, security, subscription-manager
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello-headpin-all.noarch 0:1.4.3.28-1.el6sam_splice will be installed
...
Complete!
# rpm -q katello-headpin-all
katello-headpin-all-1.4.3.28-1.el6sam_splice.noarch
# rpm -qf /etc/redhat-release
redhat-release-server-6Server-6.8.0.1.el6.x86_64


I'm going to close this as NOTABUG but if you do feel this is an issue with SAM 1.4 please feel free to re-open with a 'yum repolist -v' from the system you are seeing the above RPM error on and we can diagnose further.
Comment 2 qianzhan 2016-02-04 03:02:06 EST
(In reply to Mike McCune from comment #1)
> This doesn't look like it has anything to do with SAM 1.4, the conflicts are
> within the set of repos you have enabled for RHEL:
> 
>  rpm-build-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
>            Requires: rpm = 4.8.0-47.el6
> 
> looks like you are trying to pull from rhel-6-server-eus-rpms repo which is
> definitely not RHEL 6.8 (6.7) so you are getting conflicts. You need to have
> your system configured to pull base OS from the RHEL 6.8 compose repository
> and not EUS.
> 

Yes, I disabled all repos except rhel-6-server-rpms, and add a new repo which contains RHEL-6.8-20160125.0 build link. The installation is successful. But I met another issue:
[root@samserv ~]# katello-configure --deployment=sam --user-pass=admin
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20160204-004124/main.log]
Katello configuration: |====================================================================================================================================================================================================================|

[root@samserv ~]# katello -u admin -p admin ping
Service unavailable or restarting, try later        <======
[root@samserv ~]# katello-service status
tomcat6 (pid 4758) is running...                           [  OK  ]
httpd (pid  3283) is running...
thumbslug (pid  3474) is running...
elasticsearch (pid  1953) is running...
katello is not running.                           <====
delayed_job is not running.                       <====
delayed_job_monitor is not running.               <====
[root@samserv ~]# service katello restart
Stopping katello: 
Please run katello-configure first                <====
Starting katello:                                          [  OK  ]


Did you meet the same issue?
Comment 3 qianzhan 2016-02-18 22:02:23 EST
(In reply to qianzhan from comment #2)
> (In reply to Mike McCune from comment #1)
> > This doesn't look like it has anything to do with SAM 1.4, the conflicts are
> > within the set of repos you have enabled for RHEL:
> > 
> >  rpm-build-4.8.0-47.el6.x86_64 (rhel-6-server-eus-rpms)
> >            Requires: rpm = 4.8.0-47.el6
> > 
> > looks like you are trying to pull from rhel-6-server-eus-rpms repo which is
> > definitely not RHEL 6.8 (6.7) so you are getting conflicts. You need to have
> > your system configured to pull base OS from the RHEL 6.8 compose repository
> > and not EUS.
> > 
> 
> Yes, I disabled all repos except rhel-6-server-rpms, and add a new repo
> which contains RHEL-6.8-20160125.0 build link. The installation is
> successful. But I met another issue:
> [root@samserv ~]# katello-configure --deployment=sam --user-pass=admin
> Starting Katello configuration
> The top-level log file is
> [/var/log/katello/katello-configure-20160204-004124/main.log]
> Katello configuration:
> |============================================================================
> =============================================================================
> ===========================================================|
> 
> [root@samserv ~]# katello -u admin -p admin ping
> Service unavailable or restarting, try later        <======
> [root@samserv ~]# katello-service status
> tomcat6 (pid 4758) is running...                           [  OK  ]
> httpd (pid  3283) is running...
> thumbslug (pid  3474) is running...
> elasticsearch (pid  1953) is running...
> katello is not running.                           <====
> delayed_job is not running.                       <====
> delayed_job_monitor is not running.               <====
> [root@samserv ~]# service katello restart
> Stopping katello: 
> Please run katello-configure first                <====
> Starting katello:                                          [  OK  ]
> 
> 
> Did you meet the same issue?

I deployed SAM1.4 on RHEL-6.8-20160212.2, and this issue does not exist:
[root@dhcp-128-60 ~]# katello-configure --deployment=sam --user-pass=admin
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20160218-194331/main.log]
Katello configuration: |====================================================================================================================================================================================================================|

[root@dhcp-128-60 ~]# katello-service status
tomcat6 (pid 1774) is running...                           [  OK  ]
httpd (pid  2443) is running...
thumbslug (pid  2131) is running...
elasticsearch (pid  1173) is running...
katello (2384) is running.
katello (2399) is running.
delayed_job is running.
delayed_job_monitor is running.

Note You need to log in before you can comment on or make changes to this bug.