Bug 1303915 - unavailable for installing
unavailable for installing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 07:11 EST by Fl@sh
Modified: 2016-02-10 05:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 05:48:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fl@sh 2016-02-02 07:11:56 EST
Description of problem:
after update clang the qt-creator is unavailabe for installing

Version-Release number of selected component (if applicable):
3.6.0-2

How reproducible:
update clang , install qt-creator

Steps to Reproduce:
1.
2.
3.

Actual results:
nothng provides libclang.so needed by qt-creator-3.6.0-2

Expected results:


Additional info:
Comment 1 Sandro Mani 2016-02-02 07:33:01 EST
Builds are failing due to a possible GCC6 bug. Investigation ongoing.
Comment 2 Sandro Mani 2016-02-08 18:30:44 EST
Finally fixed in qt-creator-3.6.0-7.fc24
Comment 3 Fl@sh 2016-02-10 05:30:21 EST
dnf info qt-creator display 3.6.0-2.fc24 release;

dnf install qt-creator display since: 
    nothing provides libclang.so needed by qt-creator-3.6.0-2.fc24.i686;

dnf install https://kojipkgs.fedoraproject.org//packages/qt-creator/3.6.0/7.fc24/x86_64/qt-creator-3.6.0-7.fc24.x86_64.rpm
display:
    nothing provides libbotan-1.10.so.1()(64bit) needed by qt-creator-3.6.0-7.fc24.x86_64

this means, that new qt-creator not in rawhide repo and required botan package is'n available.
Comment 4 Sandro Mani 2016-02-10 05:36:46 EST
Are you sure you have up-to-date repository metadata? I.e. try

dnf update --refresh
Comment 5 Fl@sh 2016-02-10 05:38:47 EST
dnf cleal all && dnf update --refresh    processed
Comment 6 Sandro Mani 2016-02-10 05:40:59 EST
It seems to me that you are not getting the latest rawhide packages. Both up-to-date botan and qt-creator should be readily available from the repos:

$ rpm -qa botan
botan-1.10.12-1.fc24.x86_64
$ rpm -qa qt-creator
qt-creator-3.6.0-7.fc24.x86_64
Comment 7 Fl@sh 2016-02-10 05:48:29 EST
ok, then it my dnf problems.

Note You need to log in before you can comment on or make changes to this bug.