Bug 1303976 - [Docs] [Release Notes] Add information on watermark reporting
[Docs] [Release Notes] Add information on watermark reporting
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Dayle Parker
Shikha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 10:26 EST by Deon Ballard
Modified: 2016-04-27 20:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 21:13:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Watermark report release note, with screenshot of settings (114.07 KB, image/png)
2016-02-14 20:47 EST, Dayle Parker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 2148911 None None None 2016-02-03 12:43 EST

  None (edit)
Description Deon Ballard 2016-02-02 10:26:19 EST
Hey.

We have a reports and monitoring doc here:
https://access.redhat.com/documentation/en/red-hat-cloudforms/version-4.0/monitoring-alerts-and-reporting/

A new type of report was added in Capablanca / 5.5 to address high watermark (max usage) for different resources. Associated engineering bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=1238287 (watermark for sockets per hypervisor)
https://bugzilla.redhat.com/show_bug.cgi?id=1238288 (watermark for vms per provider)

This is the description from the doc text:

Previous CloudForms Management Engine versions did not report a high watermark for the number of virtual machine sockets on a provider's hypervisors over a one-month period. This functionality has been added to the current version of CloudForms Management Engine. A report can now be queued to collect watermark information for sockets on each hypervisor per provider.

The engineering contact is Gregg Tanzillo.


Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 2 Andrew Dahms 2016-02-02 19:05:06 EST
Looks like these two reports are there by default under All Reports > Configuration Management > Providers > Watermark *
Comment 3 Andrew Dahms 2016-02-02 19:06:42 EST
Assigning to Dayle for review.
Comment 4 Marianne Feifer 2016-02-03 12:43:33 EST
Added article with listing of all reports for 5.5.

Did this by running bundle exec rails r tools/doc/reports_to_csv.rb from /var/www/miq/vmdb/tools/doc

The resulting file is /var/www/miq/vmdb/reports.csv
Comment 5 Dayle Parker 2016-02-04 19:44:19 EST
Thanks Marianne! I'll make sure a link to that article ends up in the Monitoring, Alerts, and Reporting guide. Another bug is being created to update the Reports chapter in that guide.

Since the Monitoring, Alerts, and Reporting doc does not cover any reports specifically, it would be best to document the addition of the watermark reports to the Release Notes, so I'm changing the component for this particular bug.
Comment 6 Dayle Parker 2016-02-05 00:16:22 EST
(from comment #5)

Another bug is being created to
> update the Reports chapter in that guide.
> 

https://bugzilla.redhat.com/show_bug.cgi?id=1304934 tracks review & updates to the Reports chapter.
Comment 7 Dayle Parker 2016-02-05 00:36:09 EST
Added the following to the Release Notes in the Enhancements chapter:

Watermark reports
    CloudForms Management Engine can now report a high watermark for the maximum number of virtual machines on a provider over a one-month period, which can be used for billing. Reports can be queued to collect watermark information for host sockets per provider and for virtual machines per provider. These reports are located in the Reports menu under Configuration Management → Providers. 

Deon, Gregg, does this seem sufficient/accurate for this bug?
Comment 8 Dayle Parker 2016-02-14 20:47 EST
Created attachment 1127145 [details]
Watermark report release note, with screenshot of settings

Following feedback from the product marketing team, I've expanded the release note so there's a bit more info about what's important for the user to know, along with a screenshot. Any feedback is welcome.
Comment 11 Andrew Dahms 2016-03-09 21:13:42 EST
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.