Bug 1304059 - manila depends on unneeded httplib2
manila depends on unneeded httplib2
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity low
: ---
: 10.0 (Newton)
Assigned To: Tom Barron
Dustin Schoenbrun
Don Domingo
: Triaged
: 1304060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 14:05 EST by Eric Harney
Modified: 2016-08-31 15:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 15:28:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2016-02-02 14:05:09 EST
Manila depends on python-httplib2, but this is not a requirement as of liberty.  Should be removed from the package Requires.
Comment 2 Eric Harney 2016-02-02 14:08:25 EST
*** Bug 1304060 has been marked as a duplicate of this bug. ***
Comment 3 Eric Harney 2016-02-02 14:10:49 EST
Also probably need to remove dependencies on python-qpid, python-kombu, and python-amqplib.
Comment 4 Eric Harney 2016-03-09 19:45:15 EST
Made this change for OSP9 in python-manila-1.0.1-4.el7ost.
Comment 5 Elise Gafford 2016-07-27 10:36:59 EDT
Assigning to Tom per conversation on #rhos-storage.
Comment 6 Elise Gafford 2016-08-17 10:57:36 EDT
Spec change only: upstream feature freeze does not endanger this bug shipping in OSP 10.
Comment 7 Tom Barron 2016-08-31 15:28:20 EDT
These out-of-date dependencies are not present in the OSP10 spec.  Bug was filed for OSP8 but we do not support manila in OSP8 and do not plan to do builds there.

Note You need to log in before you can comment on or make changes to this bug.