Bug 130406 - Applet does not appear in panel
Applet does not appear in panel
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 22:41 EDT by Timothy E Miller
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 15:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy E Miller 2004-08-19 22:41:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
Applet does not appear in the panel on a new install of RHEL 3AS U2. 
It  does not start when launched from the menu.  When I try to launch
it from the terminal window, I get:

$ rhn-applet-gui
/home/millerte was not found, creating
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 47, in ?
    main()
  File "/usr/bin/rhn-applet-gui", line 43, in main
    applet = rhn_applet.rhnApplet()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 180, in
__init__
    self.consent = rhn_utils.get_user_config('Consent')
  File "/usr/bin/../share/rhn/rhn_applet/rhn_utils.py", line 95, in
get_user_config
    user_config_obj.init()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_utils.py", line 78, in init
    self.save()
  File "/usr/share/rhn/up2date_client/config.py", line 183, in save
    os.makedirs(os.path.dirname(self.fileName),0757)
  File "/usr/lib/python2.2/os.py", line 204, in makedirs
    mkdir(name, mode)
OSError: [Errno 17] File exists: '/home/millerte'

Since this was launch from a graphical login under the millerte
account, /home/millerte clearly exists (as it admits at the end).

Even the root account has this problem when launching the '-tui'
version of this software.


Version-Release number of selected component (if applicable):
2.0.12-1

How reproducible:
Always

Steps to Reproduce:
1.  Install RHEL 3AS via kickstart from a RHN Satellite server
2.  Try to start program under graphical or text login


Additional info:

$ rpm -qa | grep up2date
up2date-gnome-4.2.33-1
up2date-4.2.33-1
$ rpm -q python
python-2.2.3-5
$ rpm -q rhn-applet
rhn-applet-2.0.12-1
Comment 1 Robin Norwood 2006-10-17 15:51:35 EDT
I'm unable to reproduce this with the current rhn-applet - not sure if it has
been fixed since the bug report, or if there was some other problem causing this
issue.

Note You need to log in before you can comment on or make changes to this bug.