Bug 1304143 - keybinding with ctrl with erratic behavior in blender ( also on krita as well ) [NEEDINFO]
keybinding with ctrl with erratic behavior in blender ( also on krita as well )
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 19:55 EST by Daniel Andrade de Matos
Modified: 2016-10-11 15:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: blender-2.78-1.fc25 blender-2.78-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-08 22:44:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
luya: needinfo? (danielmatos.3d)


Attachments (Terms of Use)

  None (edit)
Description Daniel Andrade de Matos 2016-02-02 19:55:19 EST
Description of problem:

the keybinding ctrl + middle mouse button, do zoom on 3d viewport, but is just rotating the viewport, like only pressing middle mouse button alone ( this behavior is the same on krita) and some keybinding with control like ctrl + R for example has a erratic behavior sometime you need to press 2 or more times to execute the action and sometime is just like is pressing shift-alt or other key instead. 
already tested in openbox and plasma and work like expected, discarding a keyboard malfunction.

Version-Release number of selected component (if applicable):

blender 2.76 ( krita 2.9.10 , qt 4.8.7)

How reproducible:

Just open the blender, and pres Contrl plus middle mouse button

Steps to Reproduce:
1.open the blender (in default setting chould has a cube in viewport)
2.pres CTRL + middle mouse button
3.to compare press middle mouse button 

Actual results:

rotating around cube in 3d viewport 

Expected results:

zoom on cube in 3d viewport

Additional info:

The english isn't my first language, sorry before hand any misspelling, and if I don't made myself clear fell free to ask.
Comment 1 Daniel Andrade de Matos 2016-02-02 20:12:40 EST
Additional info:

This behavior happens on mypaint as well (installed from dnf), but didn't happens on mypaint builded from git upstream repository, and dosen't happens on inkscape, in case this information may be useful.
Comment 2 Fedora Admin XMLRPC Client 2016-07-29 13:31:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Luya Tshimbalanga 2016-07-30 13:20:31 EDT
Hi Daniel,
It sounds like a setting problem depending the language input of the keyboard. Could you check the "user preference" setting?
The expected result works as intended as I tested with both mouse and touchpad
Comment 4 Fedora Update System 2016-10-01 18:22:05 EDT
blender-2.78-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4573c69ac9
Comment 5 Fedora Update System 2016-10-03 03:23:33 EDT
blender-2.78-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5a10d726e
Comment 6 Fedora Update System 2016-10-08 22:44:52 EDT
blender-2.78-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2016-10-11 15:55:25 EDT
blender-2.78-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.