Bug 1304404 - [Regression] Unable to manually import not yet started EAP 5 server
[Regression] Unable to manually import not yet started EAP 5 server
Status: CLOSED ERRATA
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.3.4
Unspecified Unspecified
urgent Severity urgent
: post-GA
: One-off release
Assigned To: Michael Burman
Mike Foley
: Regression, Triaged
Depends On:
Blocks: 1228279
  Show dependency treegraph
 
Reported: 2016-02-03 09:15 EST by Radim Hatlapatka
Modified: 2016-02-18 14:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 14:00:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jon agent debug log (210.91 KB, text/plain)
2016-02-03 10:44 EST, Radim Hatlapatka
no flags Details

  None (edit)
Description Radim Hatlapatka 2016-02-03 09:15:31 EST
Description of problem:

The fix which is part of JON EAP plugin update [1] creates regression which causes that it is no longer possible to manually import EAP 5 server which is not yet running, which results in failure of the server import and [2] being thrown in server log.



Version-Release number of selected component (if applicable): JON 3.3.4 + JON EAP plugin update introduced in BZ#1228279 [1]


How reproducible: always


Steps to Reproduce:
1. In agents inventory choose to import manually EAP 5.2 server via JBossAS (JBossAS5 plugin)
2. fill correctly all needed options (naming url, principal and credential, homedir and server homedir, servername, java home, bind address, ...)
3. click finish

Actual results: server fails to be imported with message [2] in JON server log


Expected results: server is correctly imported


Additional info:


[1] md5sum
fefca118e02725b438f47768b661867a  jon-plugin-pack-eap-3.3.0.GA-update-02.zip


[2]
08:41:17,991 WARN  [org.rhq.coregui.server.gwt.ResourceGWTServiceImpl] (http-/0.0.0.0:7080-44) Sending exception to client: [1454506877991] : org.rhq.core.clientapi.agent.PluginContainerException: Failed to add resource with type [JBossAS Server] and parent resource id [10538]
	at org.rhq.core.pc.inventory.InventoryManager.manuallyAddResource(InventoryManager.java:1105)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_79]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_79]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_79]
	at org.rhq.enterprise.communications.command.impl.remotepojo.server.RemotePojoInvocationCommandService.execute(RemotePojoInvocationCommandService.java:184) [rhq-enterprise-comm-4.12.0.JON330GA-redhat-1.jar:4.12.0.JON330GA-redhat-1]
	at sun.reflect.GeneratedMethodAccessor60.invoke(Unknown Source) [:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_79]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_79]
	at sun.reflect.misc.Trampoline.invoke(MethodUtil.java:75) [rt.jar:1.7.0_79]
	at sun.reflect.GeneratedMethodAccessor57.invoke(Unknown Source) [:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_79]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_79]
	at sun.reflect.misc.MethodUtil.invoke(MethodUtil.java:279) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:112) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:46) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:237) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.PerInterface.invoke(PerInterface.java:138) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.MBeanSupport.invoke(MBeanSupport.java:252) [rt.jar:1.7.0_79]
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:819) [rt.jar:1.7.0_79]
	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:801) [rt.jar:1.7.0_79]
	at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:292) [rt.jar:1.7.0_79]
	at com.sun.proxy.$Proxy2.execute(Unknown Source)
	at org.rhq.enterprise.communications.command.server.CommandProcessor.handleIncomingInvocationRequest(CommandProcessor.java:290) [rhq-enterprise-comm-4.12.0.JON330GA-redhat-1.jar:4.12.0.JON330GA-redhat-1]
	at org.rhq.enterprise.communications.command.server.CommandProcessor.invoke(CommandProcessor.java:184) [rhq-enterprise-comm-4.12.0.JON330GA-redhat-1.jar:4.12.0.JON330GA-redhat-1]
	at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:967) [jboss-remoting-2.5.4.SP5.jar:]
	at org.jboss.remoting.transport.socket.ServerThread.completeInvocation(ServerThread.java:798) [jboss-remoting-2.5.4.SP5.jar:]
	at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:751) [jboss-remoting-2.5.4.SP5.jar:]
	at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:586) [jboss-remoting-2.5.4.SP5.jar:]
	at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:234) [jboss-remoting-2.5.4.SP5.jar:]
Caused by: org.rhq.core.clientapi.agent.PluginContainerException: [Warning] The resource [Resource[id=10489, uuid=ad093169-c3db-4f2d-852b-fff02f961f83, type={JBossAS5}JBossAS Server, key=/mnt/hudson_workspace/workspace/noe-jon/eap5secured/jboss-eap-5.2/jboss-as/server/production, name=EAP localhost:1199 production, parent=ibm-x3650m4-01-vm-06-agent-16163, version=EAP 5.2.0]] has been added but could not be started. Verify the supplied configuration values: 
	... 30 more
Caused by: org.rhq.core.util.exception.WrappedRemotingException: [Warning] Failed to start component for Resource[id=10489, uuid=ad093169-c3db-4f2d-852b-fff02f961f83, type={JBossAS5}JBossAS Server, key=/mnt/hudson_workspace/workspace/noe-jon/eap5secured/jboss-eap-5.2/jboss-as/server/production, name=EAP localhost:1199 production, parent=ibm-x3650m4-01-vm-06-agent-16163, version=EAP 5.2.0] - Failed to lookup JNDI name 'ProfileService' from InitialContext. - Cause: java.lang.RuntimeException: Could not obtain connection to any of these urls: localhost:1199
	at org.rhq.core.util.exception.WrappedRemotingException.getCause(WrappedRemotingException.java:121) [rhq-core-util-4.12.0.JON330GA-redhat-1.jar:4.12.0.JON330GA-redhat-1]
	at org.jboss.logmanager.formatters.Formatters$14.renderCause(Formatters.java:839) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.formatters.Formatters$14.access$500(Formatters.java:635) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.formatters.Formatters$14$1.run(Formatters.java:655) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.formatters.Formatters$14$1.run(Formatters.java:637) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_79]
	at org.jboss.logmanager.formatters.Formatters$14.renderRaw(Formatters.java:637) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.formatters.Formatters$JustifyingFormatStep.render(Formatters.java:224) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.formatters.MultistepFormatter.format(MultistepFormatter.java:83) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.ExtFormatter.format(ExtFormatter.java:32) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.handlers.WriterHandler.doPublish(WriterHandler.java:46) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.ExtHandler.publish(ExtHandler.java:76) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:302) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.LoggerNode.publish(LoggerNode.java:310) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.jboss.logmanager.Logger.logRaw(Logger.java:719) [jboss-logmanager-1.5.4.Final-redhat-1.jar:1.5.4.Final-redhat-1]
	at org.slf4j.impl.Slf4jLogger.log(Slf4jLogger.java:326)
	at org.slf4j.impl.Slf4jLogger.log(Slf4jLogger.java:70)
	at org.apache.commons.logging.impl.SLF4JLocationAwareLog.warn(SLF4JLocationAwareLog.java:199) [jcl-over-slf4j-1.7.2.redhat-3.jar:1.7.2.redhat-3]
	at org.rhq.coregui.server.gwt.AbstractGWTServiceImpl.getExceptionToThrowToClient(AbstractGWTServiceImpl.java:129) [classes:]
	at org.rhq.coregui.server.gwt.AbstractGWTServiceImpl.getExceptionToThrowToClient(AbstractGWTServiceImpl.java:110) [classes:]
	at org.rhq.coregui.server.gwt.ResourceGWTServiceImpl.manuallyAddResource(ResourceGWTServiceImpl.java:491) [classes:]
	at sun.reflect.GeneratedMethodAccessor691.invoke(Unknown Source) [:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_79]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_79]
	at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:561) [gwt-servlet-2.5.0.jar:]
	at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:208) [gwt-servlet-2.5.0.jar:]
	at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(RemoteServiceServlet.java:248) [gwt-servlet-2.5.0.jar:]
	at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(AbstractRemoteServiceServlet.java:62) [gwt-servlet-2.5.0.jar:]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-2.jar:1.0.2.Final-redhat-2]
	at org.rhq.coregui.server.gwt.AbstractGWTServiceImpl.service(AbstractGWTServiceImpl.java:88) [classes:]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-2.jar:1.0.2.Final-redhat-2]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.rhq.helpers.rtfilter.filter.RtFilter.doFilter(RtFilter.java:125) [rhq-rtfilter-4.12.0.JON330GA-redhat-1.jar:4.12.0.JON330GA-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.rhq.coregui.server.filter.CacheControlFilter.doFilter(CacheControlFilter.java:71) [classes:]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:231) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
	at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:150) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:344) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:854) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:926) [jbossweb-7.5.10.Final-redhat-1.jar:7.5.10.Final-redhat-1]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_79]
Comment 1 Radim Hatlapatka 2016-02-03 10:44 EST
Created attachment 1120824 [details]
jon agent debug log
Comment 2 Michael Burman 2016-02-09 05:22:01 EST
Fixed on master:

commit a367864f9eebe84c474628102bdcdfad78ac3503
Author: Michael Burman <miburman@redhat.com>
Date:   Tue Feb 9 12:21:14 2016 +0200

    [BZ 1304404] Do not catch ConnectionException, allow it as a workaround to adding non running EAP5 instances
Comment 4 Larry O'Leary 2016-02-18 14:00:13 EST
This fix/change was released in Application Platform Management Plug-in Pack Update-02 for JBoss ON 3.3.

Note You need to log in before you can comment on or make changes to this bug.