Bug 1304471 - AttributeError: 'F18_Url' object has no attribute 'partition'
AttributeError: 'F18_Url' object has no attribute 'partition'
Status: CLOSED DUPLICATE of bug 1276383
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:7661bf33942296c8b0b79c2525c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 12:57 EST by Chen-Pang He
Modified: 2016-02-03 13:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 13:02:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (5.88 MB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: anaconda.log (21.02 KB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: environ (3.62 KB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: journalctl (1.04 MB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: lsblk_output (1.45 KB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: nmcli_dev_list (2.32 KB, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: os_info (518 bytes, text/plain)
2016-02-03 12:57 EST, Chen-Pang He
no flags Details
File: program.log (4.53 MB, text/plain)
2016-02-03 12:58 EST, Chen-Pang He
no flags Details
File: storage.log (188.07 KB, text/plain)
2016-02-03 12:58 EST, Chen-Pang He
no flags Details
File: ifcfg.log (102.54 KB, text/plain)
2016-02-03 12:58 EST, Chen-Pang He
no flags Details

  None (edit)
Description Chen-Pang He 2016-02-03 12:57:13 EST
Description of problem:
I try to install Fedora from running Fedora.  I ran `anaconda --repo=http://download.fedoraproject.org/pub/fedora/linux/releases/23/Workstation/x86_64/os/ --liveinst` and it failed.

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/pykickstart/commands/method.py", line 51, in __getattr__
    return getattr(getattr(self.handler, method), name)
  File "/usr/lib/python3.4/site-packages/pykickstart/commands/method.py", line 105, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/livepayload.py", line 77, in setup
    osimg = storage.devicetree.getDeviceByPath(self.data.method.partition)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/__init__.py", line 1275, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'F18_Url' object has no attribute 'partition'

Additional info:
cmdline:        /usr/bin/python3  /usr/sbin/anaconda --repo=http://download.fedoraproject.org/pub/fedora/linux/releases/23/Workstation/x86_64/os/ --liveinst
cmdline_file:   BOOT_IMAGE=/vmlinuz-4.3.3-303.fc23.x86_64 root=PARTUUID=83ef4a27-4446-4543-9250-6fae13a768fb ro rhgb quiet LANG=zh_TW.UTF-8
executable:     /usr/sbin/anaconda
hashmarkername: anaconda
kernel:         4.3.3-303.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-kickstart-2.13-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Chen-Pang He 2016-02-03 12:57:42 EST
Created attachment 1120866 [details]
File: anaconda-tb
Comment 2 Chen-Pang He 2016-02-03 12:57:47 EST
Created attachment 1120867 [details]
File: anaconda.log
Comment 3 Chen-Pang He 2016-02-03 12:57:48 EST
Created attachment 1120868 [details]
File: environ
Comment 4 Chen-Pang He 2016-02-03 12:57:54 EST
Created attachment 1120869 [details]
File: journalctl
Comment 5 Chen-Pang He 2016-02-03 12:57:55 EST
Created attachment 1120870 [details]
File: lsblk_output
Comment 6 Chen-Pang He 2016-02-03 12:57:57 EST
Created attachment 1120871 [details]
File: nmcli_dev_list
Comment 7 Chen-Pang He 2016-02-03 12:57:58 EST
Created attachment 1120872 [details]
File: os_info
Comment 8 Chen-Pang He 2016-02-03 12:58:21 EST
Created attachment 1120873 [details]
File: program.log
Comment 9 Chen-Pang He 2016-02-03 12:58:24 EST
Created attachment 1120874 [details]
File: storage.log
Comment 10 Chen-Pang He 2016-02-03 12:58:26 EST
Created attachment 1120875 [details]
File: ifcfg.log
Comment 11 Chen-Pang He 2016-02-03 13:02:08 EST
I tried local repo, remote repo, and askmethod.  I also tried with and without liveinst.  Every trial fails.

*** This bug has been marked as a duplicate of bug 1276383 ***

Note You need to log in before you can comment on or make changes to this bug.