Bug 1304651 - c-c crashing when NM service restarted
c-c crashing when NM service restarted
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks: 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-02-04 04:27 EST by Vladimir Benes
Modified: 2016-04-12 11:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-12 11:26:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bt (36.62 KB, text/plain)
2016-02-04 05:26 EST, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2016-02-04 04:27:20 EST
Description of problem:
when Network c-c is open and NM service restarted c-c crashes.

see attached bt

Version-Release number of selected component (if applicable):
control-center-3.14.5-8.el7.x86_64
NetworkManager-1.0.6-27.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1.go into control-center
2.restart NM service

Actual results:
crash

Expected results:
no crash

Additional info:
Comment 1 Vladimir Benes 2016-02-04 05:26 EST
Created attachment 1121060 [details]
bt
Comment 3 Bastien Nocera 2016-04-12 11:11:54 EDT
I can't think of any use cases where we'd want to NetworkManager to be restarted from under a graphical session.

A rebased GNOME in a future version of RHEL would automatically get a number of fixes in that area, but given how the problem is reproduced, I'm happy to let it happen again.
Comment 4 RHEL Product and Program Management 2016-04-12 11:26:35 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.