Bug 1304652 - Create direct LUN disk from REST ignores PopulateDirectLUNDiskDescriptionWithLUNId value
Create direct LUN disk from REST ignores PopulateDirectLUNDiskDescriptionWith...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.2.6
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Allon Mureinik
Aharon Canan
: Automation
: 1304654 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 04:29 EST by Raz Tamir
Modified: 2016-03-10 02:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 05:09:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (942.62 KB, text/plain)
2016-02-04 04:29 EST, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2016-02-04 04:29:28 EST
Created attachment 1121049 [details]
engine log

Description of problem:
The PopulateDirectLUNDiskDescriptionWithLUNId key of engine config:
"When creating direct LUN disk the number of characters from LUN id to populate the description with (-1 = the full id, 0 = none, >0 = number of characters)" (Value Type: Integer)

When creating the direct LUN disk from REST API, this functionality is not working


Version-Release number of selected component (if applicable):
vdsm-4.17.19-0.el7ev.noarch
rhevm-3.6.2.6-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. engine-config -s PopulateDirectLUNDiskDescriptionWithLUNId=-1 # (For full ID)
2. Restart ovirt-engine service
3. Create direct LUN disk using REST API:
POST https://<fqdn>/api/disks 

<disk>
    <alias>direct_lun_test</alias>
    <size>1073741824</size>
    <interface>virtio_scsi</interface>
    <format>cow</format>
    <bootable>false</bootable>
    <lun_storage>
        <type>iscsi</type>
        <logical_unit id="<LUN_ID>">
            <port>3260</port>
            <target><IQN></target>
            <address><IP></address>
        </logical_unit>
    </lun_storage>
</disk>

Actual results:


Expected results:


Additional info:
Comment 1 Raz Tamir 2016-02-04 04:38:08 EST
*** Bug 1304654 has been marked as a duplicate of this bug. ***
Comment 2 Raz Tamir 2016-02-04 05:09:18 EST
I just realize that this is GUI feature only

Note You need to log in before you can comment on or make changes to this bug.