Bug 1304655 - patching rollback command incorrect
patching rollback command incorrect
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.5
All All
unspecified Severity low
: ---
: ---
Assigned To: David Michael
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 04:30 EST by Elena Renedo
Modified: 2016-02-10 01:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 02:30:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena Renedo 2016-02-04 04:30:56 EST
Document URL: https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/html/Installation_Guide/sect-Patching_JBoss_EAP_6.html#sect-Patching_a_ZipInstaller_Installation

Section Number and Name: 3.2.2.3. Rollback the Application of a Patch in Zip Form Using the Patch Management System

Describe the issue: In section 3.2.2.3. Rollback the Application of a Patch in Zip Form Using the Patch Management System on step 2 it's said the command to launch patching rollback is:
patch rollback --patch-id=PATCH_ID --reset-configuration=TRUE

But "--patch-id=PATCH_ID" option doesn't exist:

[standalone@localhost:9999 /] patch rollback --
--override-all          --override-modules      --override=             --preserve=             --reset-configuration=  --rollback-to

Suggestions for improvement: 

Additional information:
Comment 1 David Michael 2016-02-08 01:14:04 EST
I verified in Red Hat JBoss Enterprise Application Platform - Version 6.4.0.Alpha1 and I could view the following:
[standalone@localhost:9999 /] patch rollback --
--override-all          --patch-id=             --rollback-to           
--override-modules      --preserve=             
--override=             --reset-configuration=  
[standalone@localhost:9999 /] patch rollback --
So, this is not a bug.
Comment 2 Elena Renedo 2016-02-08 02:31:15 EST
Hi,

I'm using Jboss EAP 6.4.5, not 6.4.0.Alpha1 and "--patch-id=" option doesn't appear:

[standalone@localhost:9999 /] patch info
{
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "jboss-eap-6.4.5.CP",
        "patches" : [],
        "version" : "6.4.5.GA",
        "addon" : null,
        "layer" : {"base" : {
            "cumulative-patch-id" : "layer-base-jboss-eap-6.4.5.CP",
            "patches" : []
        }}
    }
}
[standalone@localhost:9999 /] patch rollback --
--override-all          --override-modules      --override=             --preserve=             --reset-configuration=  --rollback-to

Thanks.
Elena.
Comment 4 Jan Martiska 2016-02-09 02:02:45 EST
--patch-id should still work. I'm not sure why it isn't showed by the autocompleter, I'll have a look at that. It's probably a bug, but if you write the argument into CLI manually, it will work
Comment 7 Jan Martiska 2016-02-10 01:36:24 EST
Ok so just FYI, the argument name became optional in EAP 6.4+, so there you can write either
patch rollback --patch-id=PATCH
or
patch rollback PATCH
and it is equivalent.

Note You need to log in before you can comment on or make changes to this bug.