Bug 1304770 - The documentation search function links to document Chapters that are not in the TOC for the docs.
The documentation search function links to document Chapters that are not in ...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
570
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Russell Dickenson
Julie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 09:56 EST by Chuck Mead
Modified: 2017-07-27 19:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 19:48:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot 1 (103.73 KB, image/png)
2016-02-04 09:56 EST, Chuck Mead
no flags Details

  None (edit)
Description Chuck Mead 2016-02-04 09:56:27 EST
Created attachment 1121124 [details]
Screen Shot 1

Document URL: https://mysatellite/rhn/help/client-config/en-US/ch-rhnreg-ks.jsp

Section Number and Name: Chapter 7. Implementing Kickstart

Describe the issue: The link refers to a point in the Client Configuration Guide which is not accessible from the Table of Contents of the Document.

Suggestions for improvement: Fix the documents.

Additional information: I'm not really sure how the documentation works but the Table of Contents is definitely broken right now for the Client Configuration Guide and I suspect there are similar problems throughout. This is a problem for our customers and for our field consultants since the "in-system" documentation is a feature we regularly demonstrate for our customers!
Comment 1 Chuck Mead 2016-02-04 10:09:39 EST
After further review it's certain that this is not a single problem. There is a systemic issue with the in-system documentation. It's producing Internal Server Errors on search functions as well.
Comment 2 Russell Dickenson 2017-07-24 19:30:18 EDT
--------------------------------------
Attention: Jan Dobes and Tomas Lestach
--------------------------------------

This BZ ticket was raised against Satellite 5.7, and initially stated that the table of contents of the Client Configuration Guide, as shown within the web UI, was incorrect. Specifically, if you searched the in-product documentation for the term "kickstart", a chapter 7 in the Client Configuration Guide was returned.

I first logged in to a Satellite 5.8.0 (Beta) installation and browsed the in-product documentation. I compared the Client Configuration Guide's TOC within the product against that in the Customer Portal, and with the exception of 1 section, they were the same. However, the chapter count stopped at 5. This led to the question, then, of "Where is this mysterious chapter 7?" In fact there is not a chapter 7, titled "Implementing Kickstart". A quick Internet revealed that there is such a chapter in the RHN 5.0.0 Client Configuration Guide.

Also strange is that if you search the in-product documentation for "kickstart" and open "Chapter 7. Implementing Kickstart", then navigate to the document's revision history, it has a published year of "2009".

This leaves me baffled, and asking: "Why is RHN documentation contained within Red Hat Satellite 5.8.0 (Beta)"?
Comment 3 Tomas Lestach 2017-07-25 03:58:26 EDT
I see the same described behavior.

It looks like the old/outdated pages from the Client Confiuguration Guide haven't been removed for Sat 5.6/5.7. I see the first occurrence of the guides/client-config/en-US/ch-rhnreg-ks.jsp page in Mar 2009.

However Sat 5.8 is no longer affected.
Comment 4 Russell Dickenson 2017-07-26 21:32:12 EDT
------------------------
Attention: Tomas Lestach
------------------------

Thank you for your reply in comment 3. The Satellite 5.8 (Beta) build I had checked did not contain the Satellite 5.8 documentation, so I'm glad to have it confirmed that Satellite 5.8 is no longer affected.

This leads to the question, though:

How can we rectify this problem for Satellite 5.6 and Satellite 5.7? I expect a refresh of the documentation, in the respective product repositories, would solve the problem. But is this likely, given the support status of these versions?

Note You need to log in before you can comment on or make changes to this bug.