Bug 1304793 - seamonkey won't handle pdf files
seamonkey won't handle pdf files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
23
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 10:55 EST by Peter Scott
Modified: 2016-03-20 18:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 18:13:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Scott 2016-02-04 10:55:50 EST
Description of problem:
Visiting a pdf link such as http://peterscott.eu/rants/classwar.pdf
hangs Seamonkey.


Version-Release number of selected component (if applicable):
2.39


How reproducible:
100%


Steps to Reproduce:
1. "File" > "Open Web Location"
2. enter "http://peterscott.eu/rants/classwar.pdf" or similar


Actual results:
Seamonkey hangs
journalctl gives error messages


Expected results:
Seamonkey offers to download the file or opens it with a pdf plugin
like Firefox does.


Additional info:

These were from journalctl under WindowMaker:

Feb 03 18:51:10 peters /usr/libexec/gdm-x-session[1740]: (plugin-container:9594): GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
Feb 03 18:51:10 peters /usr/libexec/gdm-x-session[1740]: (plugin-container:9594): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
Feb 03 18:51:16 peters /usr/libexec/gdm-x-session[1740]: 2016-02-03 18:51:16: basic_code_modules.cc:70: ERROR: Module /lib64/libsystemd.so.0 could not be stored

These were from journalctl under Gnome:

Feb 03 18:59:52 peters mozilla-seamonkey.desktop[10707]: (plugin-container:10887): GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
Feb 03 18:59:52 peters mozilla-seamonkey.desktop[10707]: (plugin-container:10887): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
Feb 03 18:59:59 peters mozilla-seamonkey.desktop[10707]: 2016-02-03 18:59:59: basic_code_modules.cc:70: ERROR: Module /lib64/libsystemd.so.0 could not be stored
Comment 1 Dmitry Butskoy 2016-02-04 15:12:31 EST
Could you test it with safe mode? (Run in cmdline "seamonkey --safe-mode").

Does cache clearing help?
Comment 2 Peter Scott 2016-02-04 17:17:42 EST
I did those. Neither helped

Thanks
Comment 3 Dmitry Butskoy 2016-03-20 18:13:09 EDT
Works for me with SeaMonkey-2.40 and the example above.

Note You need to log in before you can comment on or make changes to this bug.