Bug 13048 - i18n related things
i18n related things
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-26 08:01 EDT by Kenneth Rohde Christiansen
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-28 03:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Czech PO file for GDM. Should be used as last patch in SPEC file (gdm-2.0beta2-26.src.rpm) (22.20 KB, patch)
2000-07-04 09:11 EDT, Milan Kerslager
no flags Details | Diff
Czech PO file - patch for gdm-2.0beta2-34 SPEC file (should be used as last line) (22.80 KB, patch)
2000-07-28 03:39 EDT, Milan Kerslager
no flags Details | Diff
Fresh cs.po file for gdm-2.0beta2-34 (21.13 KB, text/plain)
2000-07-28 03:41 EDT, Milan Kerslager
no flags Details

  None (edit)
Description Kenneth Rohde Christiansen 2000-06-26 08:01:24 EDT
The gdm redhat uses is not the exact same as the one as in the cvs of
Gnome. Therefore there are no places that it can be translated, which is
bad. Please add the pot file you use to the redhat i18n@redhat.com
translation robot

Thanks
Comment 1 David Mason 2000-06-26 10:22:44 EDT
Havoc, is this true - are we not including the pot files? If not please add them
and then ask Dale about how we can get this in the RH i18n robot even though its
not in the RH CVS.
Comment 2 Milan Kerslager 2000-07-04 09:01:16 EDT
The POT file can be buided from SRC package of RH's gdm. The easiest way is to
download gdm-2.0beta2-26.src.rpm from RH's updates, and do:

rpm -Uvh gdm-2.0beta2-26.src.rpm
cd /usr/src/redhat
rpm -bp SPEC/gdm.spec
cd BUILD/gdm-2.0beta2
./configure
cd po
make update-po

Yup - and here is fresh gdm.pot

Well. But it seems that SPEC file use old gdm.pot (without changes due to a lot
of external patches). So - can you please update SPEC file to do:

make update-po

before 'make' in your SPEC file?

Yes will be great if i18n robot can do transparent interface between
translations team and RH. Anyway I would like to submit Czech PO file as a patch
(shoul be used as the last patch in SPEC file).
Comment 3 Milan Kerslager 2000-07-04 09:08:47 EDT
Sorry - the correct line for SPEC file should be:

( cd po ; make update-po )

because main Makefile know nothing about 'update-po'. This line breaks nothing.
The only problem is that you have to have the gettext package handy for building
process.

And yes - it seems that gdm isn't localized very well. After entering wrong
login name english texts appears on screen. Welcome message seems to be
non-localized too. This is bad as GDM is prefferred default graphical login
after fresh installation.
Comment 4 Milan Kerslager 2000-07-04 09:11:31 EDT
Created attachment 878 [details]
Czech PO file for GDM. Should be used as last patch in SPEC file (gdm-2.0beta2-26.src.rpm)
Comment 5 Christian Rose 2000-07-23 19:23:20 EDT
The strings "Welcome to %s", "Login:", "Please enter your login" are
untranslated in beta4, although some of the menu items are translated (I use
Swedish).

If even the welcome screen is a translation mish-mash, I doubt many new users
will get a good feeling about their RH system. Marked it as a "Fail" in Depends.
Comment 6 Milan Kerslager 2000-07-28 03:33:02 EDT
Czech PO file synced to gdm-2.0beta2-34. Could do you add czech PO file to
buiding tree and modify line with ALL_LINUGUAS in configure.in to contain "cs"
language? I will assign patch for SPEC file and fresh cs.po file too.
Comment 7 Milan Kerslager 2000-07-28 03:39:25 EDT
Created attachment 1634 [details]
Czech PO file - patch for gdm-2.0beta2-34 SPEC file (should be used as last line)
Comment 8 Milan Kerslager 2000-07-28 03:41:09 EDT
Created attachment 1635 [details]
Fresh cs.po file for gdm-2.0beta2-34
Comment 9 Havoc Pennington 2001-07-12 15:28:46 EDT
gdm is a much newer version now, should be identical to GNOME CVS version

Note You need to log in before you can comment on or make changes to this bug.