Bug 1304805 - [RFE] Wildcard match in Smart Parameter override
[RFE] Wildcard match in Smart Parameter override
Status: CLOSED DUPLICATE of bug 1132453
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.1.6
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
Depends On:
Blocks: 260381
  Show dependency treegraph
 
Reported: 2016-02-04 11:37 EST by Tom Sorensen
Modified: 2016-02-11 07:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 07:53:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Sorensen 2016-02-04 11:37:49 EST
Description of problem:
RFE on the ability to do wildcard (glob style) or possibly regular expression matching when overriding Smart Parameters. Currently only literal matches are allowed.

Version-Release number of selected component (if applicable):
6.1.6

How reproducible:
Always


Steps to Reproduce:
1. Select a Smart Variable or Parameter from Configure->Smart Variables
2. Select Override
3. Enter a match criteria such as "fqdn=foo*.example.com"
4. Click Submit

Actual results:
Rejected for "No current hosts match"

Expected results:
Should match any hosts that start with "foo" and end in ".example.com"

Additional info:
RFE submitted by customer.
Comment 2 Bryan Kearney 2016-02-08 13:40:27 EST
Ori, does the 1.10 and 1.11 usability work address this?
Comment 3 orabin 2016-02-11 07:53:54 EST
This is a duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=1132453 and it has not been addressed.

*** This bug has been marked as a duplicate of bug 1132453 ***

Note You need to log in before you can comment on or make changes to this bug.