Bug 1304828 - "log to syslog" without a /etc/rsyslog.d/ snippet
"log to syslog" without a /etc/rsyslog.d/ snippet
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
: 1357897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 12:48 EST by Harald Reindl
Modified: 2016-07-27 14:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: logrotate-3.9.2-5.fc25 logrotate-3.9.2-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 14:52:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logrotate-journalctl.txt (8.33 KB, text/plain)
2016-07-20 07:53 EDT, Kamil Dudka
no flags Details

  None (edit)
Description Harald Reindl 2016-02-04 12:48:58 EST
* Mi Jan 20 2016 Jan Kaluza <jkaluza@redhat.com> - 3.9.2-1
- new upstream version 3.9.2
- log to syslog
_______________________________________

sorry but spit /var/log/messages full with below informations without redirect them with a /etc/rsyslog.d/ snippet to a own logifle which is *alo* properly rotatet don't improve things

Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/maillog
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/messages
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/secure
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/spooler
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: not running postrotate script, since no logs were rotated
Feb  4 03:40:02 rawhide logrotate: #012rotating pattern: /var/log/yum.log
Feb  4 03:40:02 rawhide logrotate: yearly
Feb  4 03:40:02 rawhide logrotate: (5 rotations)
Feb  4 03:40:02 rawhide logrotate: empty log files are not rotated,
Feb  4 03:40:02 rawhide logrotate: log files >= 30720 are rotated earlier,
Feb  4 03:40:02 rawhide logrotate: old logs are removed
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/yum.log
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-1 3:27, that is not year ago yet)
Feb  4 03:40:02 rawhide logrotate: #012rotating pattern: /var/log/wtmp
Feb  4 03:40:02 rawhide logrotate: weekly
Feb  4 03:40:02 rawhide logrotate: (5 rotations)
Feb  4 03:40:02 rawhide logrotate: empty log files are rotated,
Feb  4 03:40:02 rawhide logrotate: old logs are removed
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/wtmp
Feb  4 03:40:02 rawhide logrotate:  log does not need rotating (log has been rotated at 2016-1-31 3:39, that is not week ago yet)
Feb  4 03:40:02 rawhide logrotate: #012rotating pattern: /var/log/btmp
Feb  4 03:40:02 rawhide logrotate: weekly
Feb  4 03:40:02 rawhide logrotate: (5 rotations)
Feb  4 03:40:02 rawhide logrotate: empty log files are rotated,
Feb  4 03:40:02 rawhide logrotate: old logs are removed
Feb  4 03:40:02 rawhide logrotate: considering log /var/log/btmp
Comment 1 Jan Kurik 2016-02-24 09:24:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Fedora Admin XMLRPC Client 2016-06-24 07:01:40 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Kamil Dudka 2016-07-19 10:40:56 EDT
*** Bug 1357897 has been marked as a duplicate of this bug. ***
Comment 4 Kamil Dudka 2016-07-19 10:43:03 EDT
Sorry for replying late on this bug.  I will just revert the change that caused this madness...
Comment 5 Harald Reindl 2016-07-19 10:47:45 EDT
No need to revert - just ship a proper rsyslog snippet
Comment 6 Kamil Dudka 2016-07-20 07:53 EDT
Created attachment 1182087 [details]
logrotate-journalctl.txt

(In reply to Harald Reindl from comment #5)
> No need to revert - just ship a proper rsyslog snippet

There can be systems with logrotate but without rsyslog.  The output of journalctl looks really crazy with logrotate logging to syslog.  See the attachment.

I will revert the change now but I am open to discuss alternative solutions for f25+.
Comment 7 Kamil Dudka 2016-07-20 09:51:25 EDT
fixed in logrotate-3.9.2-5.fc25
Comment 8 Fedora Update System 2016-07-20 10:08:48 EDT
logrotate-3.9.2-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b2832e96e
Comment 9 Fedora Update System 2016-07-21 00:20:58 EDT
logrotate-3.9.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b2832e96e
Comment 10 Fedora Update System 2016-07-27 14:52:09 EDT
logrotate-3.9.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.