Bug 1304860 - sensu pkg in rhel-7-server-openstack-7.0-optools-rpms is too old (0.16.0) please update to 0.2x
sensu pkg in rhel-7-server-openstack-7.0-optools-rpms is too old (0.16.0) ple...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: RFEs (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Martin Magr
: TechPreview
: 1320140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 14:56 EST by Vincent S. Cojot
Modified: 2016-04-07 16:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 16:24:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sensu01 client details with sensu 0.16.0 from CDN (214.97 KB, image/png)
2016-02-05 11:50 EST, Vincent S. Cojot
no flags Details
sensu01 client details with sensu 0.20.6 from CDN (287.52 KB, image/png)
2016-02-05 11:51 EST, Vincent S. Cojot
no flags Details

  None (edit)
Description Vincent S. Cojot 2016-02-04 14:56:00 EST
* Description of problem:

rhel-7-server-openstack-7.0-optools-rpms provides this rpm:

"sensu-0.16.0-2.el7ost.noarch.rpm"

The current upstream version of 'sensu' is a lot more recent (0.22.0 at time of this writing).

I had been testing 0.20.6 from the sensu yum repos (http://repositories.sensuapp.org/yum/7/x86_64/) and it worked quite better for the following reasons:

1) the client nodes were faster to reconnect/reconfigure to the sensu server.

2) the server was faster to absorb the check results of its clients when absorbing a large number of new clients.

3) when rebooting the sensu server, the 0.16.0 rpm required some manual LTC (as in systemctl restart <svc1> <svc2>) whereas 0.20.6 did not (all services came back online sucessfully).

4) The upstream patch to display the output from the 'GREEN' checks works on 0.20.6, not on 0.16.0 (the green checks show -no- output at all).
Upstream patch: https://github.com/sensu/uchiwa/issues/404
Applying the above patch to uchiwa-0.8.1-2.el7ost.x86_64.rpm works if sensu is 0.20.6 but not if sensu is the 0.16.0 from the CDN repos.

Version-Release number of selected component (if applicable):

sensu-0.16.0-2.el7ost

Additional info:

Please consider rebasing to 0.20.6 or above.

Thank you

Vincent
Comment 2 Vincent S. Cojot 2016-02-05 11:50 EST
Created attachment 1121454 [details]
sensu01 client details with sensu 0.16.0 from CDN
Comment 3 Vincent S. Cojot 2016-02-05 11:51 EST
Created attachment 1121455 [details]
sensu01 client details with sensu 0.20.6 from CDN
Comment 4 Vincent S. Cojot 2016-02-05 11:54:45 EST
Look at the differences between the two screenshots..

With 0.16.0 + upstream patch (https://github.com/sensu/uchiwa/issues/404), there are no outputs displayed when the checks are green.

with 0.20.6 + upstream patch (since I'm using the uchiwa from CDN), tons of information are displayed.

It would be great if we could get this output with a version of sensu/uchiwa from CDN..

Thank you! :)
Comment 5 Lon Hohberger 2016-03-08 11:26:45 EST
We can look at this for Operational Tools for OSP 8.
Comment 6 Vincent S. Cojot 2016-03-08 11:34:39 EST
Hi martin,
I've noticed 0.22.0 in the repos.. Would you consider using 0.22.1 instead? It just came out..
Thank you,
Regards,
Vincent
Comment 7 Sadique Puthen 2016-03-22 22:09:39 EDT
*** Bug 1320140 has been marked as a duplicate of this bug. ***
Comment 8 Lon Hohberger 2016-04-06 15:04:26 EDT
We can look at rebasing again later, if needed.
Comment 13 errata-xmlrpc 2016-04-07 16:24:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0605.html

Note You need to log in before you can comment on or make changes to this bug.